×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Super Contributor
    Join Date
    Mar 2003
    Posts
    2,426

    Label Not found error on trying to display a simple TITLE.

    Hi All,

    I am newbie for the Symbian OS development. I executed the HelloWorld appln using the proc. given in the SDK help file.

    I tried to display a simple title and as per the instructions(ref: Crystal GUI Controls Catalog->Controls->Application title). When I compile the sample, I am getting LABEL NOT FOUND error. I was trying for only minimal configuration title display and so i havent added any codes to *.cpp files.
    I added codes to the RESOURCE Files and .hrh files.

    RESOURCE TOOLBAND r_myapp_titlebar
    {
    controls=
    {
    APPTITLE ------>LABEL NOT FOUND?
    {
    id=EHamishappApptitle; //Id of app title. Put in .hrh file
    maintitle= "Application name text";
    }
    };
    }

    Please help on this.
    Thanks
    Uva

    Posted by Yuva Kumar , yuva@trinitymobile.com
    on April 23, 2002 at 14:03

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Posts
    2,426

    RE: Label Not found error on trying to display a simple TITLE.

    Posted by Forum_Nokia Developer_Support, communicator.developer@nokia.com
    on April 25, 2002 at 10:18

    The APPTITLE struct is defined in the file:

    CKNCTL.RH

    so add:

    #include <cknctl.rh>

    at the start your resource file

    Regards,
    FN Developer Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •