×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Regular Contributor
    Join Date
    Oct 2003
    Location
    England
    Posts
    167

    Missing headers in SDK v2.0

    Am I the only one to find headers missing in the SDK v2.0 which are actually mentioned as being included in the SDK v2.0 documentation.

    GSmupdu.smuthdr.h, gsmuelem.h and others - the usual suspects.

    I'm having to use a cobbled together set of headers once again to get my code to build.

    Anyone else have this problem ?

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    UK
    Posts
    159
    Of course lots of us are having similiar problems - ripping headers from other SDKs just seems to go with the territory... :(

  3. #3
    Regular Contributor
    Join Date
    Oct 2003
    Location
    England
    Posts
    167

    Bad news

    This will be the death of Symbian when Microsoft get their act together :(

  4. #4
    Registered User
    Join Date
    Feb 2004
    Posts
    3
    Yes, I had the same problem, when I tried to compile SMS example program using SDK 2.0, too many missing header files. I had to search for these files in other SDK and changed them a little...like smutset.h, smuthdr.h, etc. Than it compiled all right, but when in the linking stage, it failed with unresolved symbols (ServiceCenterAddress, SetServiceCenterAddressL). I am still trying to figure out what happens. It looks like the library file smcm.lib does not contain those symbols anymore. Anyone have any ideas ???

  5. #5
    Registered User
    Join Date
    Mar 2004
    Location
    Manchester
    Posts
    43
    Symbian (and maybe Nokia) eally do need to get the simple things right.

    Which SDKs are you ripping the headers from?

    cheers

    John

  6. #6
    Regular Contributor
    Join Date
    Oct 2003
    Location
    England
    Posts
    167

    Meeting with Nokia

    I had a meeting with some high ranking Nokia guys from Tampere a few weeks ago, as part of the company I am currently working for. I put across many of the common complaints that we all seem to be having with support and the SDKs.

    The guys who came over, i'll refrain from naming them, agree that there are issues that they need to solve. However these things take time as Nokia is a big company and these things always do

    It seems that they are trying and realise the effect and advantage this will give to MS when they get their act together, but will they do it intime

  7. #7
    Registered User
    Join Date
    Mar 2004
    Location
    Manchester
    Posts
    43
    Do you know if any of the other SDKs have the missing files, i.e. the Series 60 SDK 2.0 Metrowerks version or the Series 60 SDK 2.1 beta version?

    Cheers

  8. #8
    Registered User
    Join Date
    Mar 2004
    Location
    Manchester
    Posts
    43

    Here are the missing files for SMS on Series 60 SDK 2.0

    Symbian Knowledge base:

    http://www3.symbian.com/faq.nsf/0/7B...3?OpenDocument

    Ensure you follow the link and also get "etelmm.h"

  9. #9
    Regular Contributor
    Join Date
    May 2003
    Posts
    96

    EMSInformationElement.h ?

    Thank you for the link.

    But what about EMSInformationElement.h which is needed by Gsmumsg.h ?

    mik

  10. #10
    Registered User
    Join Date
    Mar 2004
    Location
    Manchester
    Posts
    43

    EMSInformationElement.h

    Just comment the #include out. It seemed to be fine for me.

  11. #11
    Regular Contributor
    Join Date
    Apr 2003
    Location
    Germany
    Posts
    94
    Another missing usefull header.... plpvariant.h; GetMachineIdL is not available any more.... :(
    http://discussion.forum.nokia.com/fo...threadid=32480

  12. #12
    Registered User
    Join Date
    Mar 2004
    Posts
    27
    I am having the problem CY_ELLEN reported: unresolved externals for CSmsPDU::ServiceCenterAddress and CSmsPDU::SetServiceCenterAddress at link time.

    Does anybody know how to get over this?

    Thanks!

  13. #13
    Registered User
    Join Date
    Mar 2004
    Location
    Manchester
    Posts
    43

    smcm.lib

    Ensure your including smcm.lib in your MMP file...

  14. #14
    Registered User
    Join Date
    Mar 2004
    Posts
    27
    I actually have smcm.lib included in my mmp file. I checked the exports just in case and the ServiceCenter methods do not seem to be included. Again this is for the 2.1 SDK for 7.0s (6600).

    Any other ideas?

  15. #15
    Registered User
    Join Date
    Mar 2003
    Posts
    7
    I have the exact same problem.

    In previous versions of the SDK there were a lib called gsmu.lib that exported the externals you want. Dunno where that lib is gone. Maybe some Nokia VIP's can tell us?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×