×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Feb 2004
    Posts
    7

    Nokia 5210 BUG: AT+CPBR DOESN'T WORK!! So what other AT cmd doesn't???

    I have a common problem (already posted from someone else) in accessing the 5210 phonebook (phone firmware is v5.20 12-08-02 NSM-5).

    When I try reading (via irda), for example, the 3rd entry (or any other entry, one or many at a time) from SIM memory, I get:

    AT+CPBR=?
    +CPBR=(1,200),20,8 // just to show you: 20 max chars for number and only 8 max for the name??
    OK

    AT+CPBR=3
    +CPBR: 3,"+390123456789",145," C O M P A Q H D E<CR>+39"
    OK

    Here are my two quests:

    1 - Why the name field has a space before each character (the '<CR>' represents a carrige return char)? The real name showed on the phone display is "COMPAQ HDESK", no spaces.

    2 - Why the name is getting truncated and the truncated characters are replaced by the characters from the phone number ? i.e why the wrap around occurs?


    ANY other +CSCS terminal setting leads me to the same results.

    It is not a thing that doens't work to me, an error, or something I'm doing wrong, but a targeted 5210 phone problem!

    ONLY the 5210 model gives me these problems: tried with FIVE different Nokia models, 3 Ericsson models, 1 Siemens model, 4 Panasonic models... and had no problems with the output format of the entry-name!!

    If Nokia claims to have built-in a modem in a phone, hope you don't have to verify all -standard- AT commands (because AT+CPBR is a basic command, working on any phone-modem) before buying it...

    So, Nokia guys, since ther is no support/SDK for a "cheap" 200 euro phone like 5210, can you please tell me at least if it's a firmware bug, and if so, what version solves this problem (is there a v5.40 firmware out there?), so I can go to a service center to upgrade my phone and write this in my PocketPC application About box?


    Thank you in advance for the attention youl'd like to pay to my problem.

    Sincerely,
    Gianni
    Last edited by g3v70; 2004-02-12 at 16:50.

  2. #2
    Registered User
    Join Date
    Feb 2004
    Posts
    7
    Tried another 5210 phone with a more new firmware (v5.25): same problem.

    Nokia techs: can you please just verify this and tell if the 5210 is factory-bugged on AT+CPBR command?

    This will prevent other people to choose a model that won't give what they expect.


    Thank you in advance,

    Gianni

  3. #3
    Registered User
    Join Date
    Feb 2004
    Posts
    7
    Hello???

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •