×

Discussion Board

Results 1 to 3 of 3

Thread: !"#?&!" aiftool

  1. #1
    Registered User
    Join Date
    Jan 2004
    Posts
    7

    !"#¤&!" aiftool

    Hi.

    Hate spamming the board with my problems, but again this is so far out that help would be welcome.
    My aiftool is behaving strangely. I have the 6.1 SDK and my aiftool hangs at "Adding captions":
    Code:
    D:\cpp\projects\symbian\SMosaik>aiftool smosaik icons.mbm
    AIF tool - Unicode build
    Copyright (C) Symbian 2000
    Compiling AIF file
    Empty compile time value given to use lib at d:\software\Symbian\6.1\Shared\epoc
    32\tools/epocaif.pl line 22
    
    Reading resource file...
    Adding icons
    Reading icons
    Adding captions
    Wonder if the "Empty compile time..." message has something to
    do with it..? Now then, here is a clip of my .rss-file:

    Code:
    RESOURCE AIF_DATA
    	{
    	app_uid=0x00001337;
    	caption_list=
    	    {
    		CAPTION { code=ELangEnglish; caption="SMosaik"; }
    		};
    
    
    	num_icons		= 2;
    	embeddability	        = KAppNotEmbeddable;
    	hidden			= KAppNotHidden;
    	newfile			= KAppDoesNotSupportNewFile;
    	}
    I'm using the 7.0s SDK at work and in there the aiftool works ok. I tried copying the .aif compiled at work and use it with the 6.1 SDK, but then i still see the jigsaw -puzzle and get "System error" on the emulator and real device (7650) when I try to run the program. After i delete the .aif, the program runs.

    So any ideas what might cause this weird behaviour?

    Thanks,
    Tom

  2. #2
    Nokia Developer Expert
    Join Date
    Apr 2003
    Location
    Finland
    Posts
    425
    Hi,

    Really strange problem. I tried of your RESOURCE AIF_DATA and it is perfect and aif file is able to produce within 9210 SDK.

    Do you have two different SDK's installed on that machine. If you have, check that you use correct aiftool. I have found that sometimes if you have many SDK's installed the path could point to aiftool of wrong SDK.

    BTW Why you won't define that aif on your project file (MMP):
    Code:
    AIF sample.aif ..\aifsrc sample.rss c8 smpl_i_applic.bmp smpl_i_applic_mask.bmp smpl_i_applic_list.bmp smpl_i_applic_list_mask.bmp
    After that no need to play within weird aiftools

    Br V

  3. #3
    Registered User
    Join Date
    Jan 2004
    Posts
    7
    Thanks for your reply!

    I only have one SDK in use and it won't help if i define the AIF thing in the mmp because the aif generation is still done using aiftool, putting it in mmp just saves you from doing it manually.

    Somehow i suspect it could be my bluetooth dongle, although removing it had no effect on this. Don't know why i think so but it just looks evil enough to do something like that.

    Additional suggestions are welcome :)

    - Tom

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×