×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Feb 2004
    Posts
    4

    Downloading 3gp video over WAP - Status Codes 406

    developers,

    I have a problem with setting up a WML Deck that allows the download of 3gp video. I created a 3gp file using the Nokia 6600 and uploaded it to my site.

    I then created a WML Deck to allow a download link to the 3gp file in asp.

    ---------------------------------------------------------------------------
    <%
    'send the right MIME type
    Response.ContentType = "text/vnd.wap.wml"

    'disable caching of this deck
    Response.Expires = -1
    Response.AddHeader "Pragma", "no-cache"
    Response.AddHeader "Cache-Control", "no-cache, must-revalidate"
    %>
    <?xml version="1.0" encoding="iso-8859-1" ?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.3//EN" "http://www.wapforum.org/DTD/wml13.dtd">
    <wml>
    <template>
    <do type="prev" label="Back"><prev/></do>
    </template>

    <card title="Cyan">
    <p><a href="http://www.xxxxx.co.uk/xxx/xxxx/video.3gp">download test 3gp file</a></p>
    </card>
    </wml>


    --------------------------------------------

    The WML deck does load successfully on my Nokia 6600, but when I click on the 3gp link (which is active and working from other browsers i.e the URL is correct) I get the following error message.

    "Sorry"

    "The requested item could not be loaded!"
    "(Status Code 406)"

    Does anyone know what this means ? I have been scratching my head for a few days trying to figure out how to get this to work.

    Do I have to setup a mime on the server so that 3gp video can be sent to the Nokia 6600 ?

    Please help and thanks in advance. Any info or pointers would be appreciated.

    Regards

    Cyanwap

  2. #2
    Super Contributor
    Join Date
    May 2003
    Posts
    839
    Hello!

    Add the correct MIME Type to the server

    -Tum-

  3. #3
    Registered User
    Join Date
    Feb 2004
    Posts
    4
    @Tumpelo

    Thx!

    That worked... nice one!
    I was on the right track but I got a confirmation from the developer community here.

  4. #4
    Registered User
    Join Date
    Aug 2003
    Posts
    4
    What is the correct MIME type?

    I was try to add "video/3gpp" ".3gp" in the IIS but seem not working. I used 3650 to download and it return file type incorrect.

  5. #5
    Registered User
    Join Date
    Feb 2004
    Posts
    7

    How big is the file you are trying to download?

    We have found that smaller files download ok. We don't know yet what the limit is for a Nokia 3650. If anyone knows please let me know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×