×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Aug 2003
    Posts
    34

    Using Borland BuilderX and S60 SDK 2.0

    Hi there,

    I´m not able to use the sdk 2.0. The template "symbian OS 7.0 for borland" does not work properly.

    I get many mistakes. It seems that some files are not found. Error" ...not frozen"

    Is there a way to use the sdk 2.0 ???

  2. #2
    Registered User
    Join Date
    Aug 2003
    Posts
    34
    Hi Nokia people,

    I´ve changed to borland´s builder 6. I can compile now with SDK 2.0.

    The problem is that after compiling the code I get a status:
    "build incomplete" "1 missing".

    The file myapp.rpp in EPOC32/Localisation folder is missing. Also the folder itself.

    I´m able to run it with the emulator and on the handset.


    Does this error mean something ???

    Is there a better way to code with other IDE that WORKS fine ???


    Please answer.

  3. #3
    Registered User
    Join Date
    Oct 2003
    Location
    Sweden
    Posts
    32
    I'm having a problem when building my S60 project. I'm trying to use the 2.0 SDK in BCBX. It seems to compile and link alright, but at the very end I get:

    ...
    abld -v final WINS UDEB
    abld -c build WINS UDEB
    MISSING: \Symbian\7.0s\Series60_v20\EPOC\DATA\Z\SYSTEM\APPS\MyProject_xip.AIF
    Build cancelled due to errors

    What is the MyProject_xip.AIF file? Does anyone have an idea what's causing this?

    Cheers,
    Jonas

  4. #4
    Registered User
    Join Date
    Aug 2003
    Posts
    34
    Hi Joru,

    look in the SDK for AIF. You can build your app icons with aif builder. In the .mmp file you´ll find at the end AIF ... .aif etc.
    Make shure the paths are ok. You can delete this line if you want then your app will get the standart ugly icons.

    I hope this helps

    Regards,

    H.S.

  5. #5
    Registered User
    Join Date
    Oct 2003
    Location
    Sweden
    Posts
    32
    Thanks H.S.,

    the only thing I have in the MMP regarding AIFs is:

    AIF MyProject.aif ..\aif Myprojectaif.rss c8 context_pane_icon.bmp context_pane_icon_mask.bmp list_icon.bmp list_icon_mask.bmp

    It seems like the MyProject_xip.AIF file is something that BCBX thinks it needs to build the project, but why? And what might a *_xip.AIF file be? Weird...

  6. #6
    Registered User
    Join Date
    Mar 2004
    Posts
    5

    Missing...

    Hi,
    I get the same error too and it happens only with SDK 2.0. On 1.2 project compiles and makes perfectly.
    But its not just localization - I get several warnings
    1. \symbian_root\epoc32\include\techview - not found
    2. export frozen ... counld not find \sybian_root\epoc32\build...\filename.exp
    3.Missing \symbian_root\epoc32\localization\filename.rpp

    Did anyone solved this ?

    Thanks

  7. #7
    Registered User
    Join Date
    Oct 2003
    Location
    Sweden
    Posts
    32
    Tigor,

    my 1.2 projects also build perfectly OK.

    The MyProject_xip.AIF does not exist anywhere on my machine.
    I get the same type of error if I try to build an example SDK project, e.g. the editor example gives:

    abld -v final WINS UDEB
    abld -c build WINS UDEB
    MISSING: \Symbian\7.0s\Series60_v20\EPOC32\DATA\Z\SYSTEM\APPS\AKNEXEDITOR\AKNEXEDITOR_xip.AIF
    Build cancelled due to errors

    However, the project seems to build fine from the command prompt.

    I think there might be something wrong with my SDK configuration. When I added the SDK 2.0 from Tools -> Symbian SDK configuration... -> Add..., there was no SDK template for S60 2.0, only Symbian Series 60 1.x (Microsoft version). So I chose Symbian UIQ v7.0 (Microsoft version) instead. Since S60 2.0 is also based on Symbian OS v7.0(s), I thought this was the best option, but maybe not...

    Do you think the SDK (mis)configuration is causing these problems? Is there a BCBX SDK template for S60 2.0 anywhere?

    Cheers,
    Jonas

  8. #8
    Registered User
    Join Date
    Mar 2004
    Location
    Kuala Lumpur, Malaysia
    Posts
    2
    I'm oso having the same problem as sieber.nokia. I have search through all the websites but still cannot find any solution. I'm wondering is it the SDK 2 cannot support personal edition. Any solutions to it please let me know. Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×