×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    18

    J2ME SMS permissions ..

    Hi,

    I have wrtten a midlet to send and receive SMS. The midlet was developed using use Nokia's series 60 toolkit and SUN One Studio 4 ME.

    All works fine (well almost, seperate question to J2ME discussion board), but everytime the application sends or receives message the emulator asks me if that is allowed.

    I have set the emulator in 'real mode' (whatever that means) as well as following midlet permissions

    MIDlet-Permissions: javax.microedition.io.Connector.sms.send,
    javax.microedition.io.Connector.sms.receive

    but no joy.

    Is that a 'feature' of the emulator or will the application on the real phone behave the same way ?.

    PS : I could go and buy a phone, but I am not certain if I should get a 6600 or an Z900 !

    Thanks

    Nick

  2. #2
    Registered User
    Join Date
    Nov 2003
    Location
    Ireland
    Posts
    49
    Only a suggestion as im not very sure on this one with regard to the emulator.. but perhaps it is to do with the fact that your midlet is not trusted as it has not been signed. You will still get this message on a device until you have your midlet signed to a trusted domain.
    Brian

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    18
    Thanks for your repsonse.

    I have made some changes to the emulator settings and it all works now.

    I really need to get my self a phone and see how it behaves on the real thing

    Nick

  4. #4
    Registered User
    Join Date
    Mar 2004
    Posts
    4
    Hey Nick,

    Do let us know if it is working fine when u port the code to ur mobile...... I am facing the same prob with my 6600.

    Yusuf

  5. #5
    Registered User
    Join Date
    Apr 2003
    Posts
    11
    What did you change in the emulator to get it working?

    I am sure others have had the same if not similar problems, and it would be very helpful if people post to say how they fixed their problem for others to learn from.

  6. #6
    Registered User
    Join Date
    Mar 2003
    Posts
    18
    Hi,

    On the emulator go to
    File->Preferences->Security

    Click on Simulated and then select Custom from the drop down list.

    When you do that you can set 'Messaging' to 'Always allowed'

    However i do not know if that is something you can do on the real phone or the real device will requires certificate.

    I wonder if anybody from Nokia could clarify this.

    Nick

  7. #7
    Registered User
    Join Date
    Jul 2010
    Posts
    1

    Re: J2ME SMS permissions ..

    To get your application to skip all network prompts you HAVE TO sign the application. Emulator prompts can easily be skipped by setting your Security Domain to maximum either via your IDE or build.xml

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×