×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    26

    Deploying JAVA application in 6310i

    Hi,

    I run my application in the 6310i emulator and it's OK. The application is executed without error. Now i take the same application and i deploy it in the 6310i phone. When i try to run it, i have a file format error. I have a .jar (.class, mainifest.mf) and a .jad.

    An idea???

    Thanks,
    Yaney

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    UK
    Posts
    229

    RE: Deploying JAVA application in 6310i

    Hi Yaney,

    The 6310i is very sensitive to the details in the jad file being exactly right, and corresponding to the Manifest.mf file correcly.

    Check that the file size (in bytes) in the jad file is correct, and that the MIDlet-Vendor and MIDlet-Version match exactly what is written in the manifest file.
    The emulator doesn't seem to mind the differences, but the phone is more strict.

    Hope this helps,

    Steve

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Location
    UK
    Posts
    229

    RE: Deploying JAVA application in 6310i

    Can you post the contents of the jar file as listed with a zip tool? You can open jar files directly in WinZip, or using unzip or pkunzip with whatever the list option is.

    It's definitely the pre-verified class files that you are including in your jar?

    I know I initially had a bit of bother with the 6310i, but that was only due to the MIDlet-Vendor and MIDlet-Version properties not matching up, and the 30k limit hit me once or twice too.

    Cheers,
    Steve

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    1

    RE: Deploying JAVA application in 6310i

    HI.
    I buy this application from the nokia site for my phone and when I tried to download it to my phone I got this answer :no server access.
    they send me to my service provider to check the wap and gprs settings but they was all right,so the problem mite be at nokia ????????

  5. #5
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    51

    RE: Deploying JAVA application in 6310i

    how do you deploy it? OTA? If so, make sure you have a new firmare which means newer than 4.07.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×