×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Apr 2004
    Posts
    10

    bldmake gives ´EPOCROOT must be capitalised´ error

    Hi, I´m new at Symbian and just started working on XP. The environment is Symbian 7.0s for Series 60 v2.0 and VC++ in Visual Studio 6.0. I´m getting 'EPOCROOT variable must be capitalised' error message when I try to bldmake bldfiles. I had bldmake etc. working before and was able to get HelloWorld nicely shown on emulator, but this has changed. Ok, I must have done something, but what? And furthermore I didn´t have any EPOCROOT variable before when all seemed fine as I only added it after getting the error message that has been already discussed here: EPOCROOT does not exist. At the same time I lost the ability to build and execute the project in VC++ 6.0, but that I fixed by setting the environment to Series 60 by Environmentswitch. Unfortunately that didn't fix the original bldmake problem. Ideas?

  2. #2
    Registered User
    Join Date
    Apr 2004
    Posts
    10
    Was probably a problem with registry. 'Fixed' it by restoring to a healthy point.

  3. #3
    Registered User
    Join Date
    Jun 2003
    Posts
    20
    This is typical when the path to cmd.exe is lost from system %PATH%.

    In that case exec() calls as well as system pipe commands don't work from within Symbian toolchain perl scripts and particularly "EPOCROOT must be capitalised" comes from "e32env.pm" which fails to set session %EPOCROOT% from devices settings via system shell pipe.

    To test, try to execute for example "bldmake" command from in "C:\" and then in %WINDIR%\system32. It works in second case because perl is able to launch cmd.exe which is in that directory. To work in any other locations, add "%WINDIR%\system32" back to your system %PATH%.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×