×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Jun 2003
    Posts
    69

    CeikEdwin, with \n does not reflect a newline

    In a CeikGlobalTextEditor,

    text = "The quick brown \n fox jumps \n over";

    When i set the editors text using
    CeikGlobalTextEditor::SetTextL(text);

    when the text is displayed, the newline does not reflect on my screen.. the text is displayed on one line and just word wrapped..

    I want it to be three lines as it should...

    I tried to
    editor->RemoveFlagFromUserFlag(EEikEdwinNoLineOrParaBreaks)

    jst in case Symbian set it upon Construction, but i still have the wrong display...

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165
    one workaround would be to use line breaks that are inserted into the richtext of the editor, for example like this:

    iRichMessage->InsertL(iRichMessage->LdDocumentLength(),CEditableText::ELineBreak);

    yucca

  3. #3
    Regular Contributor
    Join Date
    Jun 2003
    Posts
    69
    got it...

    tnx dude!! :)

    ahmm, but why doesn't it work on a buffer with a "\n" on it?

  4. #4
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    and how you get rid of it when you want to read plain text? It just crossed my mind and I'm not sure if I've ever had to solve this problem...:-)

  5. #5
    Regular Contributor
    Join Date
    Jun 2003
    Posts
    69
    what do you want to get rid of? the newline characters?

    I think u could set the flag:

    editor->AddFlagFromUserFlags(EEikEdwinNoLineOrParaBreaks)

    Not yet tried this one, but i think this would work...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×