×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2004
    Posts
    1

    Downloading .jad fails from a apache-server: Unable to access file

    A simple midlet is developed with the tools Sun one Studio with the Nokia Develop Suite imported in the IDE.
    After a simple midlet was made, it was time to depoy it.
    Our server-dep. did the changes on the current Apache Web-server by to follow the procedure "Settings for the OTA Download of Midlets" ver. 1.0.
    The midlet got deployed by the Nokia dev. Suite.

    When I then tried to download by an emulator ( and an real phone), it worked fine until I started to download the .jar file.
    On timeout the following message was shown on the phone's display:

    Unable to access "filename".

    The path in the .jad file should be correct.

    Does any have some experience with this Error-message ?

    All the tools are last version.

    Regards
    --G;-))

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    jar dowloading problem

    Hi

    I had similar problems earlier, not with my Nokia phone, though.
    When I tried to download jar file with my SiemensC60 from Apache server the same message occurred. When I changed jar mime type in httpd.conf-file from 'application/x-java-archive' to application/-java-archive', everything went fine.
    There are still some problems with certain operators when using that same phone. Some operators gateways probably mess with the headers or something, but this is not an issue with Nokia models.

    TM

  3. #3
    Registered User
    Join Date
    May 2003
    Posts
    47

    Could not download jad/jar file

    Seems like you have gotten to a stage when you can download the jad file. I couldnt get to that. Can you please help me (or point me to a step-by-step doco). Here is what I am did:
    - Developed a Midlet in JBulider, transfered it to my Nokia6100 through infrared. All worked well
    - Had a copy of Tomcat running well. Copied the Jad and Jar files to a certain directory. changed the mime extension in the web-xml file (added the following) :
    <mime-mapping>
    <extension>jad</extension>
    <mime-type>text/vnd.sun.j2me.app-descriptor</mime-type>
    </mime-mapping>
    <mime-mapping>
    <extension>jar</extension>
    <mime-type>application/java-archive</mime-type>
    </mime-mapping>
    - placed the jar and jad file in a certain directory. changed the URL entry in the jad file to point to the absolute URL of the jar file
    - restarted the server

    When I enter the URL on my mobile phone (Nokia6610), it displays "Connecting via GPRS" for a long time and then returns with a message "Connection Lost, Try Again"

    Please help me diagonise the problem. Could it be because Nokai6610 supports MIDP1 while OTA is available for MIDP2.

    I would appreciate any help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •