×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    6

    can't find the application in the "other"menu of epoc emulator

    hello,everyone!
    I have a question,after I have built the examples
    provided by the Nokia series60 SDK for symbian beta 0.3,
    there aren't these applications in the "other" menu of the
    epoc emulator.For example,when i build the example "testframe",
    the step is :
    in...\nokiaex\testframe\group directory:
    bldmake bldfiles;
    abld build wins udeb;
    epoc;
    then the "other" menu of the epoc emulator shows "no data".
    i also find in the directory:
    c:\symbian\6.1\series60\epoc32\release\wins\ud

    eb\z\system\apps\testframe there is only file

    "TESTFRAME.rSC" without the file "*.app".
    i can't solve this question, anyone can help me?

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Tampere
    Posts
    475

    RE: can't find the application in the "other"menu of epoc emulator

    It seems you did the right steps and the resource file compiled. There is a possibilities, that MS Visual Studio could not able to link the files and libraries together. If none of the examples goes under "other" menu, it could be some environmental variable problem. If environmental variables of MS VS (Vcvars32.bat) and epocroot are correctly set, and the problem still exist, Please copy the dos windows(mouse right click copy it to the clipboard) here, to see which error occurred during the execution of "abld build wins udeb". (There will be warnings, but those should not make any problems like this.)

    Best Regards,
    (V) - Forum Nokia Developer support

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Tampere
    Posts
    475

    RE: can't find the application in the "other"menu of epoc emulator

    The problem is here there is an error at line: * Can't execute cpp at C:\Symbian\6.1\Shared\epoc32\tools/epocrc.pl line 161.
    Althought I could not able to reproduce this error in my computer yet, I'm sure that ..\Symbian\6.1\Shared\EPOC32\gcc\bin\cpp.exe get a wrong input somehow. The project is an example and I compiled successfully with both on WinNT,win2000 therefore the problem is not with the code. I read postings about this issue and there could be a few reasons:
    - If you use Win98, try the SDK on NT. (Although SDK 0.3 could be used withWin98, it might be some problem in some cases.)
    - If you use both N9210 SDK 1.2 and S60 b0.3 there could be that Epocroot jammed or some process during the install add some directories contain space and not the old 8.3 format name. On 98 could be the environmental space is low, means not all variables fit into it.

    The settings on win2000 which succeed with compilation: (SDK installed into C:\Symbian)
    EPOCROOT=\Symbian\6.1\Series60
    PATH=C:\Symbian\6.1\Shared\epoc32\gcc\bin;C:\Symbian\6.1\Shared\epoc32\tools;C:\Perl\bin;c:\Progra~1\Micros~3\VC98\Bin\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\Microsoft Visual Studio\Common\Tools\WinNT;C:\Program Files\Microsoft Visual Studio\Common\MSDev98\Bin;C:\Program Files\Microsoft Visual Studio\Common\Tools;

    Long directory names might not work on other OSs.

    Best Regards,
    (V) - Forum Nokia Developer Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •