×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2004
    Posts
    10

    get request problem using https in 6600

    Hi all,
    I am using socket example in sdk, when I try to send the get request
    get http://www.xxx.com... HTTP/1.0/r/n/r/n

    It is working fine, but wne I try to get the data from https

    get https://www.xxx.com... HTTP/1.0/r/n/r/n

    It is returning Bad response.

    I have also default port number as 443, and in sockets also I have added the following code extra for https.
    iSocket.SetOpt(KSoSecureSocket, KSolInetSSL);

    It is working fine in 3650 but not in 6600..

    Can anybody help what could be the problem?

  2. #2
    Registered User
    Join Date
    Sep 2004
    Posts
    1
    Hi,
    6600 is a Symbian 7 device. Thus you have to use SecureSockets. Take a look at the example in the sdk.

    Best regards,
    Philipp Henkel

  3. #3
    Regular Contributor
    Join Date
    Mar 2004
    Location
    Novi Sad - Serbia
    Posts
    63
    Hi Phogg,

    If you want to communicate using the HTTP or HTTPS and your target device is Nokia 6600, the easiest way is to create your own class derived from MHTTPTransactionCallback class.
    You should implement a few abstract functions and don't need to vory about whether you use the HTTP or HTTPS (the framework does this for you).

    You can look at the "Examples\appprots\exampleclient" and start with that example.

    Just to mention, you don't need to use sockets at all.

    Hope this can help you.

  4. #4
    Registered User
    Join Date
    Apr 2004
    Posts
    9

    Https problem

    The example code doesn't seem to be working ..
    Here is another thing as i tried to connect to www.verisgn.com .. just have a look at the code ..

    i am working on series60 3660,6600 phones,i got a problem when using RSocket and connecting to SSL enabled site,my socket couln't be able to connect to the server,I am using active object to connect to server,The following code.



    TInt KPort=443;
    iAddress.SetPort(KPort);

    const TUint32 KInetAddr = INET_ADDR(x,x,x,x);//where x's are IP numbers.
    iAddress.SetAddress(KInetAddr);

    TInt err=iSocket.SetOpt(KSoSecureSocket, KSolInetSSL,KSSLSetSecureStatus);
    iSocket.SetOpt(KSoTcpKeepAlive,KSolInetTcp);


    if(err == KErrNone)
    CEikonEnv::Static()->AlertWin(_L("Enabled"));
    else
    CEikonEnv::Static()->AlertWin(_L("Not Enabled"));

    iSocket.Connect(iAddress,iStatus);
    iHttpState=EConnecting;
    SetActive();

    when i run the program,i am getting the message Enabled means the soket is Secure Socket , But when the code Enters RunL when i check the iStatus i am getting a value of -3(KErrCancel),sometimes -4(KErrNoMemory )(very rare).I don't know where the thing going wrong.please help me out its urgent for me,Thanks in advance for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×