×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2004
    Posts
    14

    'System Error' with user FEP and 'Services' application

    Hi,

    I have written a FEP to record keypresses that a user makes on the keypad of a Nokia 3650. The scenario is that one Fep keeps track of all the keypresses and all the other feps send their keypresses to that main fep (via attributes) when a key is pressed.

    It works for all applications on the 3650 apart from in the 'services' app. In the services app, i get a "Services: System Error". Now, this happens consistantly on the device and with the emulator. The emulator debug info does *not* list any panics or access violations when this happens, so the only thing that makes me aware that something has gone wrong is the System Error message that appears on screen. I have seen no undesired effects or no program crashes when this occurs. As far as I am concerned I can carry on regardless.

    Has anyone else out there come across this or any other wierd behaviour/problems with the Services app, or are there any known issues with this application?

    I use the S60 SDK 1.2 and have a cut down version of the fep that exhibits this problem/feature.

    Thanks for your thoughts on this matter.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167
    have you checked the behaviour with FEP example, without modifications. I basically have seen thiks problem only with 7610 phones.

    yucca

  3. #3
    Registered User
    Join Date
    Mar 2004
    Posts
    14
    Hi,

    I have taken the FEP example code and added the Attribute passing which causes this bug to manifest. There isn't that much additional code to the fep.

    I send two 32 bit values when I write an attribute, and receive two 32 bit values when I read the attribute values. If the second value is 9, 10, 11, 12 or 13 then the bug appears. If I make the second value 0-8 then the bug does *not* manifest. Any value can be used as the first 32 bit value.

    I can send the source for this FEPExample for you to see so that you can either confirm a bug in services or point out what I have done wrong in the FEP.

    Thanks for any assistance,

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167
    Lets try this first:

    http://www.newlc.com/article.php3?id_article=150

    See the page and do what they say and you should get the error message to appear in more redable format, maybe it will tell what is going wrong already.

    yucca

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×