×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2004
    Posts
    1

    "authorisation failed" while installing 6600

    I have a nokia 6600
    it is open for internet, GPRS, WAP, everything...
    I am trying to install my own application via OTA (I don't have cable)
    when the installation status bar is done, I get a message "Authorisation failed".
    I could not find any one to tell me what is the problem, why is it happening and how to solve it.

    I also tried to install a very simple demo from the WTK 2.1 and a midlet from Sun's web site, all cases gave me the same message.

    does any body knows what should I do ???
    thank you

  2. #2
    Regular Contributor
    Join Date
    Jul 2004
    Posts
    52
    That usually happens when something is wrong with your JAD file.

    a) Certificate is invalid or outdate (if your midlet is signed)
    b) MIDlet-Permissions contains permissions that this phone doesn't support
    c) something else

    Triple check your Jad and compare it to something that works for sure.

  3. #3
    Regular Contributor
    Join Date
    Jul 2004
    Posts
    52
    d) You're using features that CLDC1.0 doesn't support, like floats

    You can configure WTK to CLDC1.0 but it will still compile float code happily. Phone's verifier will however fail if you have floats somewhere.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×