×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 30
  1. #1
    Registered User
    Join Date
    Jul 2004
    Posts
    6

    PC Suite error: (Code: Init IMediaControl2) HELP?!

    Hi,

    I thought I'd post a link to my problem here as not many people will go through every section looking for new posts...

    h**p://discussion.forum.nokia.com/forum/showthread.php?s=&threadid=46561

    Please help?

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,553
    I've experienced the same with PC Suite 6.1/6.2 for the 7610 and it is due to a leftover piece from an older PC Suite version (for 6600, N-Gage or whatever) that conflicts with the new one somehow.

    Uninstall all versions of PC Suite that you might have on your PC.

    Just in case, also dowload and run the PC Suite Register Cleaner:
    http://www.nokia.com/nokia/0,8764,42...9&languageId=1

    After that, fire up the Windows Registry Editor (regedt32 or regedit, doesn't matter), locate the following registry key:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]

    If there is an entry named ServiceLayer, delete it (and there should be, if you see this error ;-).

    Reboot.

    Install the latest new PC Suite from http://www.nokia.com/pcsuite

    That's been enough for me to get rid of that pesky error.

  3. #3
    Registered User
    Join Date
    Jul 2004
    Posts
    6
    Sorry bud :-(

    Already tried this and it didn't work.

    There was no "servicelayer" in the registry.

    Nokia even tried getting me to manually register some dll's from the PC Suite...

    Still didn't work!

    So eventually I gave up and burned all my stuff to CD and formatted my hard drive.

    Once I had Windows back up to spec I reinstalled the drivers and the suite and it worked :-)

    Thanks for the advice anyways dude!!

  4. #4
    Registered User
    Join Date
    Aug 2004
    Posts
    8

    IMedia Control2

    I too have gotten the Nokia Connection Manager message to please reinstall PC Suite, with code Init IMediaControl2. PC Suite doesn't recognize any phones, and Nokia Connection Manager doesn't show any phones under "Select a Phone," even after a wait of several minutes.

    I was trying to back up my 6200 to my PC using a newly downloaded Nokia PC Suite 6.2, with a serial cable. (The older version works.)

    Have tried lots of stuff...uninstalling the older version, running Nokia registry cleaner, unplugging, rebooting, reinstalling, etc.

    When I spoke with a Nokia CS Level 2 Tech today (8/24/04), he told me that he'd heard of this problem but didn't know exactly how to fix it. He believes the conflict is a result of IMedia software on my computer, whether intentionally installed or not.

    I can't find anything related to IMedia to uninstall or delete from my PC, but I'm still looking. Any advice out there?

    --Lisa

  5. #5
    Registered User
    Join Date
    Aug 2004
    Posts
    3

    Broken installation

    I have some trouble
    I have tried use RegiesterCleaner and manual remove register records but didnt work

    After I have tried manual register components.
    I have found CommonSelectDevice.dll and NokiavCard.dll did not register correctly. (regsvr32 ..., HRESULT: 0x8007007e (MSDN: 8007007e - The specified module could not be found.))
    And I have checked register for records contains CLSID

    CommonSelectDevice.SLDeviceListNotify.1 = s 'SLDeviceListNotify Class'
    {
    CLSID = s '{29AD54B2-09B8-47A8-A479-43744EFD5138}'
    }
    CommonSelectDevice.SLDeviceListNotify = s 'SLDeviceListNotify Class'
    {
    CLSID = s '{29AD54B2-09B8-47A8-A479-43744EFD5138}'
    }

    and other did not stored in the Windows Register.
    I suppose that trouble.
    Last edited by lom2k; 2004-08-25 at 22:46.

  6. #6
    Registered User
    Join Date
    Aug 2004
    Posts
    8
    Me again. More info. By googling imediacontrol, I learned that it is part of Microsoft Windows, something called DirectX (for games or videos?). Have posted to Windows XP board on Microsoft to see if anyone knows what to delete in order to get Nokia Connection Manager to work.

    --Lisa

  7. #7
    Registered User
    Join Date
    Aug 2004
    Posts
    3

    Unknown components uses by PC Suite

    suttonlisa, if you want knock to my ICQ:822228, 'll think out anything together

    See my corresponeds with Nokia Support.

    L> Hello Kathy,

    L> thank you for quickly response.

    L> I looking for errors in the installation and I found next errors:
    L> PC Suite call CoCreateInstance with parameter CLSID ==
    L> {9046A0F4-D1C9-438F-AC10-4C1B550368B3} (see attachment)

    L> This is not Microsoft trouble.

    L> I think PC Suite uses unknown component nonexistsing in the install
    L> package. google and altavista can't found this CLSID
    L> If you can contact with programmer team and inform me what I need
    L> install additional. It is very important for me.
    L> See debug log for NokiaApplicationInstall.exe in the attachment.

    L> Thank you.



    rcnc>> Dear Alex,Thank you for e-mailing Nokia's Contact Center.

    rcnc>> We understand your concern with the "HRESULT 0x8007007e."
    rcnc>> message, and are pleased to respond to your inquiry.

    rcnc>> For the quickest possible resolution to the "HRESULT
    rcnc>> 0x8007007e." concern you are experiencing, please contact
    rcnc>> Microsoft or your computer's manufacturer so they may assist you
    rcnc>> with this issue in a timely manner.

    rcnc>> Alex, if you have any additional questions, please
    rcnc>> contact us. To ensure proper handling, please continue to use
    rcnc>> the current subject line.

    rcnc>> Thank you for choosing Nokia for your mobile needs.

    rcnc>> Kathy
    rcnc>> E-mail Specialist
    rcnc>> Nokia, Inc.

    rcnc>> P.S. In an effort to continuously improve Nokia's service
    rcnc>> to you, please complete our short 8 question E-mail Customer
    rcnc>> Care Survey. Please copy and paste the following link into the
    rcnc>> address field of your web browser
    rcnc>> http://www.klcsurveys.com/surveys/nokia_feedbackt2.htm

    rcnc>> P.P.S. You can now order Nokia phones and enhancements by
    rcnc>> calling Nokia's Sales Department at 1-888-665-4228 or by
    rcnc>> visiting our web site, www.nokia.com/us! As a valued customer,
    rcnc>> we are offering a discount coupon for $5 off your next purchase
    rcnc>> of $50 or more. Please use "COUPCARE", when speaking with a
    rcnc>> representative.

    rcnc>> * Nokia e-coupon is worth $5 off of your phone accessory
    rcnc>> purchase of $50 or more. E-coupon expires December 31, 2004 and
    rcnc>> may not be combined with any other Nokia.com/us e-coupons.
    rcnc>> E-Coupons are nontransferable and valid only for phone accessory
    rcnc>> or Nokia Gear purchases made by calling the Nokia Sales
    rcnc>> Department at 1-888-665-4228 or the Nokia USA web site, URL:
    rcnc>> http://www.nokia.com/us.


    rcnc>> ----- Original Message -----

    rcnc>> From: ---@---.---.--

    rcnc>> To: reply.customercare@nokia.com

    rcnc>> Subject: Connecting Your Phone to a Computer/Internet RequestID: 1-XPDIK





    rcnc>> Email....: '---@---.---.--'
    rcnc>> First....: 'Alex'
    rcnc>> Last.....: 'Dzuba'
    rcnc>> Zip......: '00000'
    rcnc>> Model....: '6610'
    rcnc>> Order#...: ''
    rcnc>> ESN......: ''
    rcnc>> Mobile#..: ''
    rcnc>> Provider.: '0'
    rcnc>> Subject..: 'Connecting Your Phone to a Computer/Internet'
    rcnc>> OS.......: 'Windows XP Pro'
    rcnc>> WebBrowser..: ''
    rcnc>> ConnectType..: 'Infrared'
    rcnc>> NewsletterOptIn..: 'no'

    rcnc>> SearchCategory..: ''
    rcnc>> SearchTopic.....: ''
    rcnc>> SearchKeywords..: ''

    rcnc>> Message..: 'Hello Support.
    rcnc>> I have a trouble with PC Suite.
    rcnc>> After installation the program does not work correctly.
    rcnc>> When I launch ConnectionManager.exe this component shows
    rcnc>> error: Please reinstall the software(Code: Init IMediaControl2)
    rcnc>> I using IrDa connection, and infrared connection is
    rcnc>> good (I can use phone as modem).
    rcnc>> I have tried to install component CommonSelectDevice.dll
    rcnc>> manually (regsvr32.exe CommonSelectDevice.dll ) but I received
    rcnc>> HRESULT 0x8007007e.
    rcnc>> Please help me because I develop new applications for
    rcnc>> Nokia phones and I could't test it on my phone.
    rcnc>> I have found many same questions on any forums but no one knows good solution.
    rcnc>> Very thanks.
    rcnc>> P.S. but phones is very good '

    rcnc>> Server...:
    rcnc>> 'https://www.nokiausa.com/esupport/contact_us/email/confirmation
    rcnc>> - - daenusap01'
    Last edited by lom2k; 2004-08-28 at 10:08.

  8. #8
    Registered User
    Join Date
    Aug 2004
    Posts
    3

    Debug log for NokiaApplicationInstall.exe

    See debug log, I think IMediaControl2 have not any relations to this problem. I have installed DirectX SDK and full upgrades and service packs for XP.

    Debug process created...
    -PID: 724h process handle: 7C4h
    -TID: B50h thread handle 7C0h
    Dll loaded...ntdll.dll Base: 77F50000h
    Dll loaded...KERNEL32.dll Base: 77E60000h
    Dll loaded...VERSION.dll Base: 77BF0000h
    Dll loaded...SHFOLDER.dll Base: 76760000h
    Dll loaded...ADVAPI32.dll Base: 77DC0000h
    Dll loaded...RPCRT4.dll Base: 78000000h
    Dll loaded...SHLWAPI.dll Base: 70A70000h
    Dll loaded...msvcrt.dll Base: 77C00000h
    Dll loaded...GDI32.dll Base: 7E0C0000h
    Dll loaded...USER32.dll Base: 77D30000h
    Dll loaded...MFC42u.DLL Base: 727F0000h
    Dll loaded...SHELL32.dll Base: 773C0000h
    Dll loaded...COMCTL32.dll Base: 77330000h
    Dll loaded...ole32.dll Base: 7CDA0000h
    Dll loaded...OLEPRO32.DLL Base: 5F2F0000h
    Dll loaded...OLEAUT32.dll Base: 77110000h
    Dll loaded...Base: 61EC0000h
    Dll loaded...COMCTL32.dll Base: 71950000h
    Dll loaded...APISnoop.dll Base: 10000000h
    API: GetStartupInfoW(KERNEL32.dll)
    API: GetStartupInfoW returned: 0012FF64h
    API: GetModuleHandleW(KERNEL32.dll)
    API: GetModuleHandleW returned: 00400000h
    API: GetCommandLineW(KERNEL32.dll)
    API: GetCommandLineW returned: 00020950h
    API: PathRemoveArgsW(SHLWAPI.dll)
    API: PathRemoveArgsW returned: 009500ECh
    API: PathRemoveBlanksW(SHLWAPI.dll)
    API: PathRemoveBlanksW returned: 00950000h
    API: PathUnquoteSpacesW(SHLWAPI.dll)
    API: PathUnquoteSpacesW returned: 00950058h
    API: PathRemoveFileSpecW(SHLWAPI.dll)
    API: PathRemoveFileSpecW returned: 00000001h
    API: CreateFileMappingW(KERNEL32.dll)
    API: CreateFileMappingW returned: 00000040h
    API: GetLastError(KERNEL32.dll)
    API: GetLastError returned: 00000000h
    API: CoInitializeEx(ole32.dll)
    API: CoInitializeEx returned: 00000000h
    API: LoadLibraryW(KERNEL32.dll), 0043F570h="PCSL.dll"
    Dll loaded...PCSL.dll Base: A50000h
    API: LoadLibraryW returned: 00A50000h
    API: GetProcAddress(KERNEL32.dll), 00A50000h, 0043F568h="GetPCSL"
    API: GetProcAddress returned: 00A51000h
    API: LoadLibraryW(KERNEL32.dll), 0043F570h="PCSL.dll"
    API: LoadLibraryW returned: 00A50000h
    API: GetProcAddress(KERNEL32.dll), 00A50000h, 0043F568h="GetPCSL"
    API: GetProcAddress returned: 00A51000h
    API: RegOpenKeyExW(ADVAPI32.dll)
    API: RegOpenKeyExW returned: 00000000h
    API: RegQueryValueExW(ADVAPI32.dll)
    API: RegQueryValueExW returned: 00000000h
    API: RegCloseKey(ADVAPI32.dll)
    API: RegCloseKey returned: 00000000h
    API: FreeLibrary(KERNEL32.dll)
    API: FreeLibrary returned: 00000001h
    API: LoadLibraryExW(KERNEL32.dll)
    Dll loaded...Base: A60000h
    API: LoadLibraryExW returned: 00A60000h
    API: RegOpenKeyExW(ADVAPI32.dll)
    API: RegOpenKeyExW returned: 00000000h
    API: RegQueryValueExW(ADVAPI32.dll)
    API: RegQueryValueExW returned: 00000000h
    API: RegCloseKey(ADVAPI32.dll)
    API: RegCloseKey returned: 00000000h
    API: LoadLibraryW(KERNEL32.dll), 0012F8E0h="C:\Program"
    Dll loaded...Base: A90000h
    API: LoadLibraryW returned: 00A90000h
    API: CoCreateInstance(ole32.dll), 00436B00h={9046A0F4-D1C9-438F-AC10-4C1B550368B3}, 00000000h, 00000007h, 00436B10h={5B3947E6-2760-4F4C-97BE-939267CD07EA}, 0032E350h
    -------------------------------------------------------------------^ here

    Dll loaded...CLBCatQ.DLL Base: 7A170000h
    Dll loaded...COMRes.dll Base: 77040000h
    Thread created...ID: B1Ch Handle: 740h StartAddress: 77E7D342h
    Thread created...ID: A90h Handle: 73Ch StartAddress: 77E7D342h
    API: CoCreateInstance returned: 80040154h
    ----------------------------------------------^ error: REGDB_E_CLASSNOTREG

    Dll loaded...ctagent.dll Base: D00000h
    Dll loaded...SSSensor.dll Base: 6330000h
    !!! Debuggee exited...TID: B50h ExitCode: 4294967295 (FFFFFFFFh)

  9. #9
    Registered User
    Join Date
    Aug 2004
    Posts
    8
    Hi, lom2K:

    I appreciate your detailed response, but it was over my head. (I don't even know how to knock.) I'm not a developer, just a tenacious, frustrated basic consumer. But today I replied by email to Andrew, my Nokia Customer Care person, and asked him to look at this thread (which includes the info you provided).

    In my email I included, "With this additional information, please further explore the failure to successfully use Nokia Connection Manager. Like the developer, I think highly of Nokia products, but my inability to back up my phone via PC Suite is a serious problem to me."

    Will share anything useful. Thanks!

    --Lisa

  10. #10
    Registered User
    Join Date
    Aug 2004
    Posts
    8

    My solution to Init IMediaControl2 problem

    After installing PC Suite 6.2 downloaded from Nokia's U.S. site, www.nokiausa.com, I always got a popup error message when opening Nokia Connection Manager: "Connection to Nokia PC Suite failed. Please reinstall Nokia PC Suite. (Code: Init IMediaControl2)"

    I am using a Nokia 6200 phone, with a DKU-5 cable and a Nokia cradle, on a PC with Windows XP Home.

    With paid support from Microsoft, I disabled 3rd-party Services (under System Configuration Utility), then reinstalled PC Suite 6.2. Still 6.2 didn't work.

    What DID work: I uninstalled 6.2, downloaded the recently released (9/3/04) version, PC Suite 6.3, from Nokia's European site, www.nokia.com, and that version worked! (Even though that version doesn't specifically support my phone.)

    Trying to narrow down the problem, I uninstalled 6.3 and reinstalled 6.2, and THAT worked. Weird, huh?

    I'd be interested to hear if installing PC Suite 6.3 fixes this problem for you too.

    Thanks for your help. --Lisa


    If installing PC Suite 6.3

  11. #11
    Registered User
    Join Date
    Aug 2004
    Posts
    8
    Just a little more info....

    I just found a FAQ on this exact problem on Nokia's European site:

    http://www.nokia.com.au/nokia/0,,54841,00.html#01

    I HAD downloaded and ran Nokia's Register Cleaner 2, to no benefit. This FAQ says Nokia's Register Cleaner 2.1 (different version) would have worked. I guess installing PC Suite 6.3 gave me the same fix. Whatever, I'm glad to have full use of my phone's capabilities again!

    Another thing: The problem had nothing to do with Windows Service Pack 2. I had the same problem before and after installing that.

    --Lisa

  12. #12
    Registered User
    Join Date
    Dec 2004
    Posts
    2
    I have tried the solution of downloading v2.1 and I still get this error under XP Pro SP1.

  13. #13
    Registered User
    Join Date
    Aug 2004
    Posts
    8
    Jongi,

    Sorry the Nokia Register Cleaner v2.1 didn't work for you. As I wrote earlier, I didn't try v2.1, because my problem was already fixed after I replaced the U.S. PC Suite 6.2 with the European PC Suite 6.3.

    --Lisa

  14. #14
    Super Contributor
    Join Date
    Apr 2005
    Location
    Turku, Finland
    Posts
    509

    Re: PC Suite error: (Code: Init IMediaControl2) HELP?!

    I don´t think this errormessage neccessarily has to do with the leftover of the ServiceLayer in the;

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]

    I have got the same errormessage when installing PC Suite 6.6 on a clean OS with Windows XP, SP2. I have latest Windows Installer, logged in as admin, no firwall/antivirus enabled.

    I think it more has to do with that the .dll files packed in the installation pack of PC Suite, for some reason is incorrect installed. Can someone with a working version of PC Suite post a list over the folders and .dll files that are installed?!

    If then, it should be possible to download the current .dll files (or just copy them from a working version) and then reboot the computer so the keys are registered. Or if still not, register those .dll files manually.

    Can someone confirm if this could work??

  15. #15
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,553

    Re: PC Suite error: (Code: Init IMediaControl2) HELP?!

    There's now a better Register Clean utility available: http://www.nokia.com/faqsearch/ShowQ...false&qt=clean

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×