×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2004
    Posts
    4

    unable to install. invalid version error

    hi all.
    i am trying to install a java application onto my nokia 6600 . OS v4.09.1.

    i get an "unable to install. Invalid version"
    error when i try to install my midlet.jad or midlet.jar file.

    i really dont know what version of what this is talkin about. i have the latest version of symbian from nokia (well latest in australia anyway) .

    any help would be greatly appreciated as i have really hit the wall on this one now.

    cheers

    troy

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    10
    It might be worth checking that your .jad and jarfile's manifest specify the MicroEdition-Configuration and MicroEdition-Profile attributes correctly,
    and with identically matching values in both?

    e.g.
    MicroEdition-Profile: MIDP-2.0
    MicroEdition-Configuration: CLDC-1.0

    (Also the 6600 supports CLDC-1.0, in
    case you might have specified CLDC1.1
    by mistake?)

  3. #3
    Super Contributor
    Join Date
    Mar 2003
    Location
    Israel
    Posts
    2,280
    Also, check that the MIDlet-Version attribute in the jad matches the same attribute in the manifest.mf file in the jar (and all of the other attributes in the manifest have to match as well).

    shmoove

  4. #4
    Registered User
    Join Date
    Jul 2004
    Posts
    4
    thanks guys... turns out that latest symbian os in australia from nokia is 4.09.... still with CLDC 1.0

    i think the current os is v7.0 ?? does anyone know
    a) where to get it from?
    b) how to install it to the phone?

    thanks for replyin

    troy

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    10
    The Symbian OS version for the 6600 is v7.0, e.g. see here: http://www.forum.nokia.com/main/0,,016-1611,00.html

    The software version of the phone, seen from pressing '*#0000#' is the version of software the phone was e.g. flashed with.
    A v4.09 (or later) software version includes Symbian v7.0, MIDP 2.0+CLDC1.0, etc.

    You might be able to get a new software version for a particular phone (if needed for some reason) from e.g. a phone shop (by reflashing a phone, so a backup is good to do first).

    If you haven't done so already, I might suggest trying to download some of the sample MIDP 2.0 MIDlets (from Forum Nokia first though:
    http://forum.nokia.com/main/0,6566,0...3-&fileID=5004
    ) to your phone.

    I download MIDP2 MIDlets all the time to one 6600 with v4.09 software.

    (If you use WTK, you might also try to use the 'OTA download' feature to test your MIDlet via WTK.)
    Last edited by jareilly; 2004-07-30 at 11:23.

  6. #6
    Registered User
    Join Date
    Jul 2004
    Posts
    4
    cheers..
    the problem was that i want to use floats in my app. CLDC 1.0 doesnt support floating point numbers as i have found out... i would love to download the latest symbian... but i am unsure on how to install it to the phone. there is some pins in the back of it that i think are used for that but i dont know how to set it up.. thanks for the advice.. i got around my problem by changing all floating point numbers to strings and converting the strings to floats when they got to the server. once again thanks for the help

    troy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×