×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Paris, France
    Posts
    47

    Help Using Tls !!!

    Hi,

    I'd like to use the Tls with the 9200 SDK v1.2.
    When I build my application (.app) using a call to Dll::SetTls, I've got the 2 following error messages (same under SDK v1.1) for ARMI target :
    "undefined reference to 'Dll::SetTls(void *)'"
    and
    "relocation truncated to fit: ARM_26 Dll::SetTls(void *)"

    I have the "LIBRARY euser.lib" line in my mmp project file.

    I've got the same errors with the sample source code provided with the SDK (TLS2 in Epoc32Ex\System\ThreadsAndProcesses directory).

    Do you know if use of Tls is possible for Symbian 6.0 (9200 SDK) ?

    (Note : My PC is under Windows 2000)

    Thank's

    TrickLo.

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    132

    RE: Help Using Tls !!!

    Hi,

    The Tls functions are defined in a separate stub library for ARMI target. Try adding the edllstub.lib in your project .mmp file:

    LIBRARY edllstub.lib euser.lib

    Br,
    FN Developer Support

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    26

    RE: Help Using Tls !!!

    I have same problem.
    After I added edllstub.lib in *.mmp file, I got this error.

    undefined reference to `UserSvr::DllSetTls(int, void *)'

    Which lib file do I need to add for UserSvr class?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×