×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Aug 2004
    Posts
    3

    5140 mms ota provisioning

    Hi!

    I would like to configure a nokia 5410 for mms. I use the following provisioning document:

    <?xml version="1.0"?>
    <!DOCTYPE wap-provisioningdoc PUBLIC "-//WAPFORUM//DTD PROV 1.0//EN" "http://www.wapforum.org/DTD/prov.dtd">
    <wap-provisioningdoc>
    <characteristic type="PXLOGICAL">
    <parm name="PROXY-ID" value="192.168.210.002" />
    <parm name="NAME" value="Swisscom MMS" />
    <characteristic type="PORT">
    <parm name="PORTNBR" value="8080" />
    </characteristic>
    <characteristic type="PXPHYSICAL">
    <parm name="PHYSICAL-PROXY-ID" value="PRX1" />
    <parm name="PXADDR" value="192.168.210.002" />
    <parm name="PXADDRTYPE" value="IPV4" />
    <parm name="TO-NAPID" value="NAP1" />
    <characteristic type="PORT">
    <parm name="PORTNBR" value="8080" />
    </characteristic>
    </characteristic>
    </characteristic>
    <characteristic type="NAPDEF">
    <parm name="NAPID" value="NAP1" />
    <parm name="BEARER" value="GSM-GPRS" />
    <parm name="NAME" value="Swisscom MMS" />
    <parm name="NAP-ADDRESS" value="event.swisscom.ch" />
    <parm name="NAP-ADDRTYPE" value="APN" />
    <characteristic type="NAPAUTHINFO">
    <parm name="AUTHTYPE" value="PAP" />
    <parm name="AUTHNAME" />
    <parm name="AUTHSECRET" />
    </characteristic>
    </characteristic>
    <characteristic type="BOOTSTRAP">
    <parm name="NAME" value="swisscom MMS" />
    </characteristic>
    <characteristic type="APPLICATION">
    <parm name="APPID" value="w4" />
    <parm name="TO-PROXY" value="192.168.210.002" />
    <parm name="NAME" value="Swisscom MMS" />
    <parm name="ADDR" value="http://mms.natel.ch:8079/" />
    </characteristic>
    </wap-provisioningdoc>

    This settings work for example for nokia 6600 and 3220. But on this device, although I could save it and I activated it, I did not receive the mms messages. Sending mms message was not a problem. And my GPRS settings work just fine, too.

    I would be happy to hear any suggestion. Does anybody else have similar problem?

    Thanks,
    Balint

    PS. Here is the message content encoded:

    01062F1F2DB69181923241323742453644354632314441444136353839464138393245413942383038304234413439443600030B6A273139322E3136382E3231302E303032005377697373636F6D204D4D530038303830004E4150310045C65101871506830001870706831001C65301872306831D0101C65201872F06035052583100018720068300018721068501872206832201C65301872306831D01010101C65501871106832201871006AB01870706831001870806036576656E742E7377697373636F6D2E636800018709068901C65A01870C069A01870D01870E010101C65601870706037377697373636F6D204D4D53000101C60001550187360000060377340001870001390000068300018707068310018700013400000603687474703A2F2F6D6D732E6E6174656C2E63683A383037392F00010101

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    12
    Most(?) of the OMA OTA compliant phones do not accept unencrypted OMA provisioning messages(6600 does though)

    Try userpin method for instance.

  3. #3
    Registered User
    Join Date
    Aug 2004
    Posts
    3
    Well I use exactly USERPIN method for MAC calculation and it just works fine. I am asked the pin code, and lets me save, and activate.

  4. #4
    Super Contributor
    Join Date
    May 2003
    Posts
    839
    Hello!

    The device 5140 use OMA Client Provisioning 1.1, read more about :
    Technologies
    Device Management and Data Synchronization
    OMA Client Provisioning


    -tum-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×