×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Jun 2004
    Posts
    86

    regarding connectivity framework

    hi!

    im trying to run applications using bluetooth. i do not have any bluetooth cards on my pc, so i just downloaded the nokia connectivity framework 1.1.

    i have series 60 sdks already installed, namely: version 1.2 nokia edition, version 2.0 nokia edtion, and version 2.1 for codewarrior. i have already changed the bt.esk of each sdk as follows:
    for version 1.2:
    hcidllfilename = hci.dll
    port = 4
    for version 2.0:
    hcidllfilename = hci_h4.dll
    port = 5
    for version 2.1:
    hcidllfilename = hci_h4.dll
    port = 6

    after this, i started the environment (in the nokia connectivity framework), and tried to run a bluetooth application. my problem is that whenever i try to run the multiplayer mode for the version 2.0 emulator, it crashes on me, saying that epoc.exe has performed an illegal operation and will be shutdown. i tried tinkering with the communications>>bluetooth folder in the emulator (i thought that if i switch on the bluetooth for 2.0 emulator, it will all be fine) but again, it crashes!
    the version 2.1 emulator, does not crash and i think it works fine.

    also, i have recently downloaded series 60 sdk version 2.1 nokia edition. i tried the example BTEnvironment of the connectivity framework. i tried sending a note via bluetooth on the emulator from the 1.2 nokia edition to the 2.1 nokia edition emulator. It says "Cannot establish bluetooth connection". I tried it the other way around (from 2.1 emulator to 1.2 emulator), it also shows the same error. On the connectivity framework, it says "Failed to create connection handle from 000036127B35 to 000034127B35. Another connection handle is already..." What does this mean?


    has anybody experienced this? please help. thank you very much.

  2. #2
    Regular Contributor
    Join Date
    Oct 2004
    Location
    India
    Posts
    138

    I am also having the same problem if you have a solution let me know,

    Hi flicker,
    I have series60sdk2.0 and series60sdk2.1 installed on my PC,
    i am also having the same problem, please let me know if you have solved the problem.

    Thanks in Advance

    chaitu

  3. #3
    Regular Contributor
    Join Date
    Jun 2004
    Posts
    86
    hi ruchaitu!

    sad to say, i haven't found a solution to my problem. i resorted to debugging on the actual devices instead of using the emulator. could you please inform me if you get the chance to resolve this problem? thanks!

  4. #4
    Regular Contributor
    Join Date
    Sep 2004
    Posts
    69
    I got mine to work just fine! Make sure you do the following:

    * Download Setting_Up_And_Using_Bluetooth_HW_With_Development_Tools_v1_1_en.pdf
    which is titled "Setting up and using bluetooth hardware with development tools". It looks like they just updated this document this month to work with Series 80 devices as well.

    * Then go to section 7 "Setting up the emulator", and follow the instructions *exactly*. It is not enough that you made the changes you mentioned in your post. The port numbers have to match what the connectivity framework sets them to, and you also have to watch out for the fact that there is a "-1" issue with the port settings. For example, if your bluetooth COM port is 5, then you need to put 4 in the bt.esk file.

    If you follow all the instructions, it works. I haven't done too much testing, so I don't know how far you can get with the emulator, but at least the BT example applications do work.

    Good luck!
    Last edited by entell; 2004-10-22 at 14:15.

  5. #5
    Regular Contributor
    Join Date
    Jun 2004
    Posts
    86
    hi entell!

    i made sure that the port in the bt.esk matched the COM port settings in the connectivity framework. i was able to pair the two devices (test 1 on the "Setting Up" document), but i could not do the test 2, that is sending the note to the other device. The sending device says that it "could not establish a bluetooth connection".

    Do you have a bluetooth hardware in your PC? Maybe the reason why i could not test bluetooth connections on the emulator is because i do not have a bluetooth hardware?

  6. #6
    Regular Contributor
    Join Date
    Sep 2004
    Posts
    69
    I don't have any BT hardware. I am running the NCF on my laptop running WinXP.

    I did this last week. I remember running at least a few of the example BT apps and I remember them working, but I didn't try every single one. Maybe not all of them work.
    Last edited by entell; 2004-10-25 at 14:39.

  7. #7
    Regular Contributor
    Join Date
    Oct 2004
    Location
    India
    Posts
    138

    I got a solution.,

    Hi flicker,
    i faced the following error on the connectivity framework when i tried to run my own BT program using obex objects,

    "Failed to create connection handle from 000036127B35 to 000034127B35. Another connection handle is already..." What does this mean?

    now it is working fine, the reason is :
    when i opened the connectin for the first time, i need to close it so that i ccan use the connectin later, but if u dont close it gives an error for the next attempt,
    (i am a newbee, i am not sure wether this is the right answer are not, i feel this should be).,

    one more thing is for ur BT environment to work make sure that
    one single bi-directional arrow exists b/w the two emulators
    or
    2 uni-directional arrows exists b/w the two emulators

    refer the connectivity framework for how to connect thses devices.

    chaitu

  8. #8
    Regular Contributor
    Join Date
    Oct 2004
    Location
    India
    Posts
    138

    Correction of the previous posting.

    I am sorry
    i have posted some wrong imformation,

    >one single bi-directional arrow exists b/w the two emulators
    or
    >2 uni-directional arrows exists b/w the two emulators

    the link which i mentioned in the earlier message need not be present, as a default connection b/w the emulators exists and it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×