×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    10

    Signed midlet update error: "Unable to install. Downloading failed."

    anyone ever receive this message when trying to update a signed midlet. i get this problem on a 6600 and a 7610 when trying to install a signed midlet on top of another signed midlet....sometimes.

    anyone know what causes this and how to fix it?

    i can install an unsigned midlet on top of the signed one just fine.

    even going into the manager, removing it and installing again does not solve. there seems to be some leftover cruft somewhere.

    thanks in advance.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Bangalore,India
    Posts
    2,146
    what do u mean when u say install one signed midlet over the other..are u updating one midlet by the other or what?
    ciao

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    10
    yes, trying to just put a new version of a midlet on top of an older version.

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    10
    interestingly, the phone never even tries to download the jar before displaying the error message (as far as i can tell by looking at the server logs).

    must be a caching problem with the certificates not matching.

  5. #5
    Registered User
    Join Date
    Nov 2005
    Posts
    9

    Re: Signed midlet update error: "Unable to install. Downloading failed."

    assumptions:
    1. u used wtk from java.
    2. you debugged ur code.

    my suggestion:
    1. clean and re-built ur code
    2. remember to re-package to recreate .jar file
    3. install and try (should be ok by now if ur code builds)
    Yours Sincerely,
    michael

    "Never try, never know."

  6. #6
    Super Contributor
    Join Date
    Feb 2004
    Location
    Dallas
    Posts
    605

    Re: Signed midlet update error: "Unable to install. Downloading failed."

    These are the few things u ask urself and try ...it wil work.

    1.Is the device any operator specific or u bought it from the open market.If it is operator specific device, u need to get the operator certificate or third party certificate which is approved by operator.
    2.Make sure u added the permissions correctly in the JAD file.
    3.How are u signing it.Is it ur own certificate ? Is the certificate supported by ur phone..If not u need to add ur certificate to the root certificates.
    4. Make sure that u are installing using JAD file and not JAR file as few platforms cross check the entries in Manifest against the JAD file entries.
    Java platforms on different phones behave differently .So even if it works on Nokia, dont assume that it wil work on other phones as well without any porting issues.
    Please post here if u still have issues ..

  7. #7
    Super Contributor
    Join Date
    Feb 2004
    Location
    Dallas
    Posts
    605

    Re: Signed midlet update error: "Unable to install. Downloading failed."

    And just to answer Mayank's question ..
    Mayank, we can install one JAD on top of already installed JAD.There is no issue with it.

  8. #8
    Regular Contributor
    Join Date
    Oct 2004
    Posts
    321

    Re: Signed midlet update error: "Unable to install. Downloading failed."

    I am also getting same error.


    But the thing is the jad file is having relative path to jar file location.

    if full jar file path is given then the application is installed properly

    but all jad file will not be having full path for jar file

    can any one help me in this regard

    its urgent

    VK

  9. #9
    Regular Contributor
    Join Date
    Aug 2006
    Location
    Rawalpindi, Pakistan
    Posts
    486

    Re: Signed midlet update error: "Unable to install. Downloading failed."

    guys why cant u remove the previous midlet install the new version one after signing. is this also gives a problem.
    Regards
    Nouman

  10. #10
    Regular Contributor
    Join Date
    Aug 2006
    Location
    Calgary,Alberta,Canada
    Posts
    78

    Re: Signed midlet update error: "Unable to install. Downloading failed."

    This was happening to me as well and it turned out that my midlet(either jar file name or the midlet itself) name was too long and the phone didn't even try to download the jar file. I shortened it and it installed fine.
    Rupinder Deol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×