×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Aug 2004
    Posts
    16

    6600 Network problem

    hi
    first problem:
    I try sockets sample , but this sample does not work.
    In Emulator browser work well.
    whats the matter?

    second problem:
    I make sis file. it installed in emulator and work well.
    but it can not installed 6600 device.
    how ca i solve this problrm?

    I use series 60 sdkv2 in visual c 6.0
    please help me.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169
    firstly, you get your answers a lot easier if you separate different questions in different posts.

    Anyway for both questions. What excatly happens ? how you do the things ? what is the behaviour ? any error notes shown etc..

    yucca

  3. #3
    Registered User
    Join Date
    Aug 2004
    Posts
    16

    First problem

    Thank you for your advise.
    I make socket program ,but connection failed.
    there is TCP server on my computer .the IP address of my computer is 192.168.0.1. Emulator's ip address is 192.168.0.100.
    my code is follow.

    //my code here

    RSocket iSocket;
    RSocketServ iSocketServer;
    TInetAddr addr;
    TBuf<32> iServerName;
    ...

    iServerName <- "192.168.0.1";
    ...
    iSocketServ.Connect();
    addr.Input(iServerName);
    iSocket.Open(iSocketServ, KAfInet, KSockStream, KProtocolInetTcp);

    iAddress.SetFamily(KAfInet);
    iAddress.SetPort(iPort);
    iAddress.SetAddress(aAddr);


    iSocket.Connect(iAddress, iStatus);

    but connection was failed with iStatus = -1.
    I am not sure what is error in my code.
    Please help me.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169
    Try setting the address like this:

    TUint32 Addr = INET_ADDR(192,168,0,1);

    iAddress.SetPort(iPort);
    iAddress.SetAddress(Addr);

    iSocket.Connect(iAddress, iStatus);

    , if it doesn't work, try with some weel known port, such as 80 again and see if it makes any difference.

    yucca

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×