×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Sep 2004
    Posts
    1

    CodeWarrior EPOCROOT problem

    Hi
    When I try to compile a Series60 Example I get the following message:
    __________________________________________________

    Error : Symbian Resource - ERROR: Must set the EPOCROOT environment variable BEGIN failed--compilation aborted at
    C:\Symbian\8.0a\S60_2nd_FP2_CW_B\epoc32\tools/E32env.pm line 51.
    Compilation failed in require at
    C:\Symbian\8.0a\S60_2nd_FP2_CW_B\epoc32\tools/epocrc.pl line 27.
    BEGIN failed--compilation aborted at
    C:\Symbian\8.0a\S60_2nd_FP2_CW_B\epoc32\tools/epocrc.pl line 27.

    Error : Compile failed
    __________________________________________________

    But the problem is, as far as I can see, that the EPOCROOT path mentioned in the error is actualy correct. The only problem I see is the last slash "/E32env.pm" which is turning the wrong way. If thats not the problem I don't know what it could be. The problem is that that slash was inserted by the compiler or CodeWarrior and I don't really know how to correct it.

    I have set the EPOCROOT to point at the correct path, and the default device is set to Series60, even though thats not required when using CodeWarrior, so please help....

    I have no problem compiling and running UIQ 2.1 examples, even when the EPOCROOT and device is set to Series60 in the Windows enviornment...

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359
    The problem seems to be that you are building a Symbian 8.0 project with CodeWarrior version 2.5. You must upgrade to 2.8.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×