×

Discussion Board

Results 1 to 5 of 5

Thread: s60 sdk

  1. #1
    Regular Contributor
    Join Date
    Jul 2004
    Posts
    201

    s60 sdk

    I have install s60 sdk 2.0 and vc6 to develop program for nokia 6600.
    But I need develop for 3650 too.
    Someone tell me that I should install s60 sdk 1.2.

    Please tell me whether s60 sdk1.2 and sdk2.0 can install a same PC.

    And how to make the program is compiled by sdk 1.2, but not sdk 2.0 if the sdks is installed in a same PC?

    How to make the default simulator is sdk 1.2?

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    Yep, you can have as many SDKs on one PC as you wish. Please, check "EpocSwitch" application in your SDK (in Series60Tools/ directory)... There is an help that will tell you how to configure the whole stuff so you can very easily switch between various SDKs...

  3. #3
    Regular Contributor
    Join Date
    Jul 2004
    Posts
    201

    I did not find "EpocSwitch" application in Series60Tools fold

    I did not find "EpocSwitch" application in Series60Tools fold.
    There are four sub folds in Series60Tools fold, only applicationwizard,environmentswitch,epoctoolbar,mbmviewer.

  4. #4
    Regular Contributor
    Join Date
    Mar 2004
    Location
    Mobile Village - IN
    Posts
    78

    EPOC

    If you've got multiple Symbian SDK's on your PC you'll need to make sure the EPOCROOT environment variable is correct when you compile OPL programs for the Series 60. This can be checked and changed in one of two ways. The GUI method is by right-clicking on My Computer and choosing Properties. Then go to the Advanced Tab and choose Environment variables. In the list of system variables you'll see the EPOCROOT value which should be set to \Symbian\6.1\Series60\. If it's not then use the edit button to update it. If you want to use the command line then open up a command prompt and type:

    set EPOCROOT

    to check the current value. If it's incorrect then simply type:

    set EPOCROOT=\Symbian\6.1\Series60\

  5. #5
    Registered User
    Join Date
    Sep 2004
    Posts
    17

    environmentswitch

    You can use environmentswitch from Series60Tools folder. Epocswitch was in SDK 1.2. You can find there also documentation on how to use environmentswitch. You can take a newer version of environmentswitch from a newer sdk.

    Best regards,
    DC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×