×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Oct 2004
    Posts
    3

    Problems installing the Nokia SDK on Linux

    Hi,

    I'm trying to install the Nokia SDK for Symbian/6.0 on my Linux machine. I'm using the instructions on this site:

    http://www.ki-ag.de/pages/tech/Symbi..._on_linux.html

    I'm at the stage where I'm trying to compile GCC. When I run it, I get this output:

    Code:
    [scott@localhost sdk2unix-1.2]$ bin/install_gcc539 /home/scott/symbian/gcc539src.zip /home/scott/sdk
     
    ### Unpacking and UNIXifying
    unzip -q /home/scott/symbian/gcc539src.zip 
    chmod -R u+wx src
    find src -type f -print | xargs recode -f dos..latin1
     
    ### Configure, compile & install
    mkdir obj
    cd obj; sh ../src/configure --prefix=/home/scott/sdk --target=arm-epoc-pe >/dev/null 2>&1
     
    cd obj/bfd; make > /dev/null 2>&1
    cd obj/libiberty; make > /dev/null 2>&1
    cd obj/opcodes; make > /dev/null 2>&1
    cd obj/binutils; make install > /dev/null 2>&1
    cd obj/gas; make install > /dev/null 2>&1
    cd obj/ld; make install > /dev/null 2>&1
    cd obj/gcc; make LANGUAGES="c c++" > /dev/null 2>&1
    Unexcpected error: aborting.
    Does anyone know what the problem might be?

    Thanks

  2. #2
    Registered User
    Join Date
    Oct 2004
    Posts
    3
    I've removed all the "> /dev/null"s from the code and I see several pages of text ending with this:

    ../../src/gcc/move-if-change tmp-genrtl.h genrtl.h
    ../../src/gcc/move-if-change tmp-genrtl.c genrtl.c
    touch s-genrtl
    gcc -c -DCROSS_COMPILE -DIN_GCC -g -DHAVE_CONFIG_H -I. -I../../src/gcc -I../../src/gcc/config ../../src/gcc/c-lex.c
    In file included from ../../src/gcc/c-lex.c:32:
    c-parse.h:54: error: conflicting types for `RETURN'
    ../../src/gcc/rtl.def:515: error: previous declaration of `RETURN'
    make: *** [c-lex.o] Error 1
    Unexcpected error: aborting.

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    2

    Problems installing the Nokia SDK on Linux

    I had similar kind of problems some time ago when I tried to build this with the Mandrake 10.0.

    As the gcc 2.9x based toolchain needed for running symbian binaries (even working pretty well and producing guite good code) is rather old, it turned out that the the newer versions of other tools used as a help during the build were too new and were not backward compatible enought to get gcc 2.9x to be compiled out of the box.

    (gcc 2.9x was normally used about the time of RH 7.2 and with that the build should go without big problems)

    Instead of spending time for trying to get gcc build with Mandrake 10, I just downloaded and prebuild gcc binaries from http://www.gnupoc.org/ and started using them for my development)

    I am dreaming that Nokia could release symbian SDK for the Linux so that in the future I would not need to spend so much time for configuring S60 development support for Linux a piece by piece. (and it would be nice to have native emulator instead of requiring wine)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×