×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Nov 2004
    Posts
    5

    Porting application from Catalina to Charlie

    Hi,

    Is there any specific procedure or way of porting an application which works well on catalina Series60 but the UI messes up in case of compilation forCharlie.

    What would be the necessary changes required to do this porting.

    Your help comments are greatly apprecated.

    BR

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165
    hmmm, people might know better if you would stick on using public model numbers for the phones..

    yucca

  3. #3
    Registered User
    Join Date
    Nov 2004
    Posts
    5

    Question again

    Sorry about that,

    Well actually i ned to move the application from Series60 SDK on Nokia6600 to Series60SDk of Nokia6630. I hope that would help better.

    It works fine on the 6600 but on the 6630 the UI messes up what could be the reason, i have compiled the RSS files again and made sure they build again.

    Thank you for the reply though.

    Regards

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165
    did you build the 6630 version with right SDK, might help. The 6600 is OS 7.0s phone and 6630 is OS 8.0a phone, so there is plenty of differences between them.

    Also the 6630 is stilll a prototype and dunno how good the SW is on it. Anyway, what you mean by "messes up the UI" ?

    What is the behaviuor observed there ?


    yucca

  5. #5
    Registered User
    Join Date
    Nov 2004
    Posts
    5

    Compiles well but execution problem

    Hi Yucca,

    Yes i did compile it on the 6630 SDk and it compiles well but while execution the icons for the UI are not related to the corresponding text, such as qtn_options_ok and text_softkey I guess these belong to the system, show up as the same(qtn_options etc) rather than there corresponding texts.

    I think it is concerned with some library to have been changed but have no idea which one these belong to. I guess i could use my own text strings but it would really help if it would work without the change.


    Thank you very much with the help though it is greatly appreciated.

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×