×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Nov 2004
    Posts
    2

    Multiple Opens, RSocket, No Data Received

    Hi

    I have a strange problem with my socket connections.

    I have a small application which downloads a large file from a webserver (to test gprs performance).
    This test is run twice or more.

    Now my problem is the second time i try to download the file Recv() or RecvOneOrMore() never return(no data received) but according to my packetsniffer my server sends out the data just fine. Until of course the device says its buffer is full with a Zero Window TCP packet.

    First i thought this is only on the emulator (Series 60 SDK 2.1) but it is happening on my device(Siemens SX1 as well)

    Any ideas why this happens?

  2. #2
    Registered User
    Join Date
    Nov 2004
    Posts
    2
    Ok found out it had nothing to do with the socket. It was my Active Object which was causing the problem.

    But now that my download app works great on the emulator i tried it on the device(Siemens SX1)

    It works great when using the Datacable as connection to the internet, but as soon as i want to use GPRS to download stuff it hangs at the Recv call.

    Tested with other applications(Opera, Basic Browser) that my GPRS connection work for them.

    Strange...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×