×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Mar 2004
    Location
    India
    Posts
    67

    Active Object Issue....File Downloaded suceesfully from sockets but.........

    Hi,
    I m estabilishing the socket connection and able to suceesfully dowload a file.
    Everything is on right track but somehow when i trying to delete that socket objects, My code get paused and did not execute further,
    And specifically when i am trying to delete the SocketWriter object it happens. This SocketWriter is my class...which writes the http request.
    Im using the SDK example code of socket version 6.0 for 3650.I had modified that and used it.
    See its like that in my SocketsEngine class where i try to Disconnect the socket connection.....

    void CSocketsEngine:isconnect()
    {
    __ASSERT_ALWAYS(iEngineStatus == EConnected, User::Panic(KPanicSocketsEngine, ESocketsBadState));
    // cancel all outstanding operations
    // since we are connected, the only possibilities are read and write
    iSocketsReader->Cancel();
    iSocketsWriter->Cancel();
    iSocket.Close();
    }

    and when it comes to line....... iSocketsWriter->Cancel().... then
    In DoCancel() of SocketWriter

    void CSocketsWriter:oCancel()
    {
    // Cancel asychronous write request
    iSocket.CancelWrite();
    iTimer->Cancel();
    iWriteStatus = EWaiting;
    }

    It executes first two statements ...BUT when it executes ....iWriteStatus = EWaiting;
    ...my control stops and does not move further. Actually it pauses.

    And one more thing if i write a dailog before calling the Disconnect() in SocketEngine class............then everything works fine without any problem and pauses.
    Please guide my way through.
    Thanks
    -Alok

  2. #2
    Registered User
    Join Date
    Aug 2004
    Location
    Hyderabad,India
    Posts
    808

    help me..

    Dear alokkumarsingh ,

    I am also doing the same by modifying socket example given in sdk and using 3660 phone. but when i asked to connect my socket is not getting connected. it is giving timed out error. i tried with a time out of 10 minutes. then also i couldn't get the solution. i am using Hutch GPRS . The same i tried with midlet and it's working fine.

    Shall i have to do any modifications to GPRS settings.

    Can u post some code snippet at the socket connect portion.

    I am trying to connect to my server from last one week. but couldn't succeed.

    Can u help me,

    Regards,
    Sudhakar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×