×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Sep 2004
    Posts
    12

    Proxy filter on 6630

    I want to use the IAP proxy settings automatically when settings up a session.
    According to nittin mitals post you could set up a HTTP connection using the CHttpFilterProxyFilterInterface after opening the session, but before starting a transaction. This works fine on S80 devices, tested on 9300 and 9500 but silently kills my app on the 6630. The connection is started, and when the connection is setup the app dies without any error messages. Has anyone encountered the same problem? Is there another way to use the proxy settings for the IAP? I get the same result if I set up the address and port for the proxy on a per transaction basis.

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    1
    Hi,

    We are facing the same. The code is runngin well (including proxy connections) on other V2 phones and on the 9500.
    It crashes on the 6630, with Panic StringPool 4 (which is not documented it seems).

    Did anybody get it running and can help us out here?

    Cheers

    Matthias

  3. #3
    Registered User
    Join Date
    Mar 2003
    Location
    Switzerland
    Posts
    19
    Hi,

    We have the same problem.
    Is that a generale Symbian 8.0 bug or is it only on 6630?
    Did you find an other way?

    Thanks!
    Eidelen

  4. #4
    Registered User
    Join Date
    Sep 2004
    Posts
    12
    No, I havent found any more information about the problem and so it isn't solved. We check the device model before doing any HTTP stuff and dont install the filter if it is a 6630. This, ofcourse, prohibits the user from choosing a IAP with proxy settings.

  5. #5
    Registered User
    Join Date
    Oct 2004
    Location
    Paris
    Posts
    29

    Workaround...

    FYI I think we have a workaround that consist into:

    - reading the proxy params from the commDB table (try search PROXIES on SDK FP2 help)
    - manually configure the proxy as explained here:
    http://discussion.forum.nokia.com/fo...roxy+filter%2A


    It seems to work, but I did not test it intensively. To avoid side effect, I prefer to keep using CHttpFilterProxyInterface() if machine uid is different from 0x101fbb55 (Nokia 6630)...

    Hope this help!
    Regards

    Adrien

  6. #6
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Tampere
    Posts
    475
    Hi,

    StringPool is a Symbian OS API:
    http://www.symbian.com/developer/tec...2dpool%2eindex

    "StringPool 4" is equal EStringTableNotFound

    The Nokia 9500 and 9300 based on Symbian OS 7.0s and behave very similar , meanwhile the Nokia 6630 is based on Symbian OS 8.0a. Even though CHttpFilterProxyFilterInterface implementation is quite the same.

    Best Regards,
    (V) - Forum Nokia Developer Support

  7. #7
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    113

    Re: Proxy filter on 6630

    Hi all,

    as add-on info: I have seen it only in firmwares earlier than 4.03.18. Thus we first check for this and if it's earlier we dont use the proxy filter.

    br, Marcel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •