×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Dec 2004
    Posts
    4

    First step into development)

    Tall me please what i need for development application for mobile phone Nokia N Gage QD
    I read that i need Series 60 SDK v1.2 for C++ or
    Series 60 SDK v1.2 for CodeWarrier.

    But can i use Series 60 2nd Edition SDK for Symbian OS, Supporting Feature Pack 2, For C++, Supporting CodeWarrior
    for example?

    Because i get Series 60 1.2 SDK for Symbian OS, Nokia Edition
    and it dosn't work correctly, some errors whit a link part(i tryed to compile example helloworld)

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169
    you can not use a ny of the 2.X SDK's, simply because they are for OS 7.0s and onwards, and N-Gage's are OS 6.1 phones still.

    BTW. What is the error you are getting ?

    yucca

  3. #3
    Registered User
    Join Date
    Dec 2004
    Posts
    4
    i do

    bldmake bldfiles

    and than

    abld build wins udeb

    and i have a error

    error link: don't know how "" is tranclete

    it's inte .make file. As i understand abld utils generate make file with a error

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169
    which IDE are you using ?

    Anyway, could you also copy-paste the whole error line, it would be a lot easier to figure out the reason.

    yucca

  5. #5
    Registered User
    Join Date
    Dec 2004
    Posts
    4
    I do next (for Epoc32Ex\HelloWorld)
    1. bldmake bldfiles
    2.abld makefile vc6
    3.open dsw file with the MS Visual Studio 7
    4.try to compile an have a error

    fatal error U1073: don't know how to make ""

    i think the problem is in the file hellowworld.wins

    it's a line from this file.

    "$(EPOCTRGUDEB)\$(TRGDIR)\HELLOWORLD.APP" : $(LINK_OBJS) "" "$(EPOCSTATLINKUDEB)\EDLL.LIB" $(LIBS)

    "" - it's a error as i think

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169
    basically EDLL.LIB is ok to be missing and you don't need to worry about it at all. In case it is the only error you get, you should have got it working basically already.

    yucca

  7. #7
    Nokia Developer Expert
    Join Date
    Apr 2003
    Location
    Finland
    Posts
    425
    Hi

    >> 2.abld makefile vc6
    >> 3.open dsw file with the MS Visual Studio 7

    I think there is a problem using VS 6 makefile on the VS7 IDE environment. There was some tricks what must be done before succees compile. Search more from www.symbian.com.

    If your SDK support only VS6 my suggestion is to use VS6 to compile. It makes life easier :-)

    Br V

  8. #8
    Registered User
    Join Date
    Dec 2004
    Posts
    4
    I found a problem. I downloaded SDK version for Nokia - it's not right version for development (as i understod). And then i downloaded SDK for CodeWarrior version and now it's OK.

  9. #9
    Registered User
    Join Date
    May 2007
    Posts
    2

    Re: First step into development)

    Yeah, even compiling using the Sisar interface doesn't work..It compiles but it doesn't execute on my phone..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×