×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Dec 2004
    Location
    Palmas - TO - Brazil
    Posts
    8

    BuilderX dont build: nmake issue

    I have Installed Borland Builder X 1.5 and Nokia SDK 2nd edition for MS Visual Studio and Borland BuilderX.
    I tried to compile the Helloworldbasic example. everiting apears to work fine, but when trying to Run, the app icon dont apears in the emulator. so I turned on the builder log, and in the log i got this msg:

    VCToolkitInstallDir=C:\Arquivos de programas\Microsoft Visual C++ Toolkit 2003\
    windir=C:\WINDOWS
    BCBX=C:\Borland\CBuilderX1.5
    process_begin: CreateProcess((null), nmake -nologo -x - -s -f \Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\HELLOWORLDBASIC.WINS WHATUDEB, ...) failed.

    make (e=2): O sistema não pode encontrar o arquivo especificado. (System can´t find specified file)


    make: *** [WHATHELLOWORLDBASIC] Error 2


    note: I use Windows XP Portuguese, text in red is the error msg translated by me :P

    So, reading this I think the builder is missing the nmake file... I have instaled the MS SDK framework 1.1, as mentioned in the download page of BuilderX 1.5 ... then I added to "Path" a reference to nmake file, "C:\Arquivos de programas\Microsoft.NET\SDK\v1.1\Bin". Now the builder returns this error in the msg window (before editing "path" there was no errors) :

    bldmake -v bldfiles
    abld -v makefile WINS
    perl -S makmake.pl -D \SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC WINS
    abld -v reallyclean WINS UDEB
    NMAKE : fatal error U1052: file '\Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\HELLOWORLDBASIC.WINS' not found
    perl -S ermdir.pl \Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\
    Clean finished
    bldmake -v bldfiles
    abld -v export
    abld -v makefile WINS
    perl -S makmake.pl -D \SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC WINS
    abld -v resource WINS UDEB
    NMAKE : fatal error U1052: file '\Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\HELLOWORLDBASIC.WINS' not found
    abld -v library WINS
    NMAKE : fatal error U1052: file '\Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\HELLOWORLDBASIC.WINS' not found
    Compile finished
    abld -v target WINS UDEB
    NMAKE : fatal error U1052: file '\Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\HELLOWORLDBASIC.WINS' not found
    abld -v final WINS UDEB
    abld -c build WINS UDEB
    MISSING: NMAKE
    MISSING: :
    MISSING: fatal
    MISSING: error
    MISSING: U1052:
    MISSING: file
    MISSING: '\Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\HELLOWORLDBASIC.WINS'
    MISSING: not
    MISSING: found
    MISSING: Stop.
    abld -w build WINS UDEB
    Build finished


    Whats wrong now?
    Last edited by fabiano_pmj; 2004-12-29 at 18:22.

  2. #2
    Registered User
    Join Date
    Dec 2004
    Location
    Palmas - TO - Brazil
    Posts
    8
    is something wrong in this configuration?
    http://fabiano.pmj.sites.uol.com.br/zoe/variables.JPG

    note: if u cant open the image, copy the URL then past in a new browser window.
    Last edited by fabiano_pmj; 2004-12-29 at 18:48.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×