×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Dec 2004
    Posts
    16

    Build Error

    i can not build the example source in the sdk, with C++BuilderX
    it gives these errors:

    bldmake -v bldfiles
    'perl' is not recognized as an internal or external command,
    'perl' is not recognized as an internal or external command,
    abld -v makefile WINS
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    abld -v reallyclean WINS UDEB
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    Clean finished
    bldmake -v bldfiles
    'perl' is not recognized as an internal or external command,
    'perl' is not recognized as an internal or external command,
    abld -v export
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    abld -v makefile WINS
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    abld -v resource WINS UDEB
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    abld -v library WINS
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    Compile finished
    abld -v target WINS UDEB
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    abld -v final WINS UDEB
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    abld -c build WINS UDEB
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    abld -w build WINS UDEB
    'abld' is not recognized as an internal or external command,
    External process exited with error code : 1
    Build finished

    Can you tell me what is the problem??
    Last edited by InsOMniaCCodER; 2004-12-31 at 11:43.

  2. #2
    Regular Contributor
    Join Date
    Nov 2004
    Location
    California, USA
    Posts
    121
    Either perl is not installed on the machine or your path is not correct. perl can be downloaded from http://www.activestate.com/ among others.

    Once you install it, the complaint about the abld.bat file sould go way too.

    -jk

  3. #3
    Registered User
    Join Date
    Dec 2004
    Posts
    16
    kernj i did what you said and thanks to you "perl error" gone. But now i am getting a link error :

    'LINK.EXE' is not recognized as an internal or external command

    i have searched the forum and found some posts but they are not clear for me :
    http://nkn.forum.nokia.com/forum/sho...threadid=36564

    i dont use VC++, and even i dont have it. in fact i dont understand why we should have a perl interpretter, why we should have VC++ linker... Am i missing something or what?

    i reinstalled everything and now i have Borland C++BuilderX 1.5 Mobile Edition, S60 2nd FP2 SDK, ActivePerl 5.8.6....

    Please help me for solving these meaningless problems. İ want to code something for symbian as soon as possible....

    Thanks again...

  4. #4
    Regular Contributor
    Join Date
    Nov 2004
    Location
    California, USA
    Posts
    121
    From the output, I see that the second argument to the abld script is wins. This is for building on VC++. It should be winsb for borland.

    -jk

  5. #5
    Registered User
    Join Date
    Dec 2004
    Posts
    16
    i dont know what is wins, what is winsb and how to configure it. But i have downloaded .net framework and .net framework sdk and it is compiled the "helloworldbasic" example without any error. then emulator (epoc i think) was started but i dont see "hello world" in the screen . it just like a phone menu but i dont understand what should i do.

    but after that i tried "graphics" example but it gave the same :
    'abld' is not recognized as an internal or external command

    error. i am still waiting your recommendations.

  6. #6
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    After startup of the emulator you should find the icon of your example application in the root directory...

    > 'abld' is not recognized

    It most probably means that you forget to run this command:
    bldmake bldfiles

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •