×

Discussion Board

Results 1 to 5 of 5

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    6

    Question Java apps on 9500 don't work

    Hi, I tried to run standard "Hello world" example and some other ones in emulator and they are working fine. Then I installed the jars on my Nokia 9500 and started them. All applications give me kernel error #3 at start and then don't work in normal way.
    I wonder what is wrong with my commy. Did somebody face the same problem?

  2. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Switzerland
    Posts
    18
    Are you sure you compiled for Java 1.3 (and not for 1.4 or 1.5)?

    I have no problems to compile Java apps and run them on the 9500 (apart from the many bugs) provided they use an AWT GUI (and not Swing nor stdin/stdout).

    Andreas

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    6
    Thank you for the response!
    According to docs I did compile it using java sdk 1.4.1. Compiled it using 1.3.1 and got the same result. Used command line approach, not WSDD. BTW, original jar files for examples don't work on my device too. I have russian localized commy.

  4. #4
    Registered User
    Join Date
    Mar 2003
    Location
    Switzerland
    Posts
    18
    So it maybe really is a bug related to localization. You may also want to try http://www.garzotto.ch/9500.html The jars you find there are supposed to work. If they don't, there definitely must be something wrong with your 9500 or its configuration.

    Andreas

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    6
    Changed device language to english and it starts working!
    Thank you for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×