Hello All.
I'm trying to save bitmap to jpeg. The code you can see below create empty files on real device and files of 607 bites on emulator (both are invalid and cannot be opened). The bitmap saved by call to Save method of CFbsBitmap object before compression can be opened without problem. So I have a problem in conversion (I think).

The status after save finished is always 0x80000001.
What do I wrong? What does it mean?

This is a code:
...
TUid id;
id.iUid = 270484952; // JPEG - from type enumeration

m_pEncoder = CImageEncoder::FileNewL(m_Fs, sFilename, CImageEncoder::EOptionNone, id);

// I tried these 2 strings as alternative, but it just stucks
// _LIT8(KMimeTyp,"JPG");
// m_pEncoder = CImageEncoder::FileNewL(m_Fs, sFilename, KMimeTyp);

if (m_pEncoder) {
TJpegImageData* data = new (ELeave) TJpegImageData;
data->iSampleScheme = TJpegImageData::EColor444;
data->iQualityFactor = 95;
m_pFrImgData = CFrameImageData::NewL();
User::LeaveIfError(m_pFrImgData->AppendImageData(data));

m_pEncoder->Convert(&m_Status, *m_pBitmap, m_pFrImgData);

// as alternative I tried also to use default third paramter NULL
// result exactly the same

SetActive();
}
else
...

void CJpegSaver::RunL()
{
// Operation complete

// m_Status.iStatus here is always 0x80000001
....
}

Thanks in advance.
Yuri.