×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jan 2005
    Location
    Taipei, Taiwan
    Posts
    11

    preverify failed

    Hi,
    I'm new user and now trying to use NDS2.2/Eclipse3.0/ANT/jdk1.4.2_06/winxp sp2 being my SDK/IDE environment.

    But there's 2 problems during Build process.

    1) with preverification failed
    I've inserted the "Series_60_MIDP_Concept_SDK_Beta_0_3_1_Nokia_edition/lib/classes.zip" into ANT Runtime classpath, also insert this file when build one java project, and use the command line to preverify the class. It still can't work and show "preverify failed!".

    followed is the error messages,
    [wtkpackage] JAR file creation failed with error -1
    [wtkpackage] The preverified classes if any are in tmp41.
    BUILD FAILED: D:\NokiaMIDP\Lab\Lab_05501.1\starter\build.xml:216: Preverification failed (result=1)

    how to config the whole classpath ?

    2) Emulator not appear
    I pass this process to set the parameter of preverify to "false" and finally appear "build successful" !
    But why can't show the emulator that I set ?


    Thanks for all comments !

  2. #2
    Registered User
    Join Date
    Jan 2005
    Location
    Taipei, Taiwan
    Posts
    11

    it's ok

    Hi,

    I got the answer from the antenna homepage. There are 2 points,
    1) because it didn't have the jar.exe in JRE direction.
    2) just need "antenna-bin-0.9.11.jar" to be put in the ANT/lib. This version has fixed the prefervify problem!

    And it's the smooth process that can see the message of "build successful"!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×