×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    153

    Problem with starting .exe from app

    Hi,i'm a newbie to symbian community


    I have a small problem starting an .exe from an application,i could able to get the function for it but it is not working,Please help me



    -----------------------------********************-------------------------------

    _LIT(KName, "c:\\system\\Apps\\123\\123.exe");


    EikDll::StartExeL(KName);

    ---------------------------********************-----------------------------------


    My problem is that how can i refer the .exe file as i couldn't able to get from the path specified.For that matter all the .exe's are under tge directory \epoc32\release\wins\udeb

    Please Help me in this regards,

    Thanks in Advance,

    Cheers,
    Sunil

  2. #2
    Super Contributor
    Join Date
    May 2003
    Location
    Vancouver, Canada
    Posts
    985
    May be you have to move your .exe file to \epoc32\wins\udeb\z\sytem\programs or \epoc32\c\system\programs.

    You can specify the target path of your .exe in the .mmp file. For example:

    TARGETPATH \system\programs

    Antony

  3. #3
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    153
    Thanks for ur prompt respose Mr.Antony,

    I have done copying the file to the location you have specified,but it is not working. I have one doubt regarding this,when we click on the .exe file we get the emulator window and the required output without giving any TARGETPATH in .mmp file.But when i changed the TARGETPATH as specified by you and to go that directory and click the .exe file,it is giving an error.I have changed the .exe path in my application to this new one but couldn't able to get the required output.

    Correct me if i'm wrong as i was new to this.

    Thanks in Advance,

    Sunil

  4. #4
    Super Contributor
    Join Date
    May 2003
    Location
    Vancouver, Canada
    Posts
    985
    If you cannot even launch your .exe from Windows explorer, it means something wrong with your program. May be you can check first with a simple Hello World program and see what happens.

    Antony

  5. #5
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    153
    Hi Antony,

    I was trying the basic helloworld program and the same problem exists i.e, the .exe file is not executing and showing the error "THE APPLICATION FAILED TO INITIALIZE PROPERLY". But i'm able to execute the .exe file from the default location without setting the TARGETPATH i.e, \epoc32\release\wins\udeb

    Please suggest me a solution to the above problem.

    Thanks in Advance,
    Sunil

  6. #6
    Super Contributor
    Join Date
    May 2003
    Location
    Vancouver, Canada
    Posts
    985
    Have you tried your program on the device? May be this problem is only on the emulator.

    Antony

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×