×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Dec 2004
    Posts
    9

    2nd Edition SDK for Symbian OS Support

    hi,
    Can i use 2nd ed symbi application over nokia 6600.... is tht SDK supports SIP.
    thankx,
    Ashu

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    Yes, if you want develp applications for N6600, S60 v2.0 SDK is the right choice. You can get SIP plugin for this SDK on Nokia's pages.

  3. #3
    Registered User
    Join Date
    Jan 2005
    Location
    Italy
    Posts
    639

    about SIP

    Hello,
    sorry if this results in a second post, but i can't see my previous one.

    You mentioned the SIP stack, so maybe this is the right thread...

    I'd like to develop on my Nokia 6630 using the SIP stack recently released. I already installed the Series 60 2nd Edition SDK for Symbian OS, Supporting Feature Pack 2, For C++, _without_ installing the suggested IDEs.
    I was able to compile, install on the phone and run the Hello World application, so i think that it's the right direction anyway.

    When i tried to install the SIP SDK, it complained about the fact that i don't have the Series SDK 2.1 installed....

    Is it possible to use the SIP SDK with my installation? Is there another way to do the same thing? Any help/suggestion would be very appreciated!

    tia,
    all the best
    jo'

  4. #4
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    That is a very good question. And I'm afraid that it is up to you to test it if it works with Symbian 8.0. My recomendation would be to install S60 v2.0 or v2.1 with correct version of SIP plugin and create the application in these SDKs, because there is currently no SIP plugin for v2.6 of the S60 SDK.

  5. #5
    Registered User
    Join Date
    Jan 2005
    Location
    Italy
    Posts
    639
    hummm... and do you think that SDK 2.0 or 2.1 will be able to create app runnable on 6630? In fact, the sdk suggested in the 6630 pages is the one i downloaded and installed...

    as an alternative, maybe i could install SDK 2.1, make it the default, install the SIP SDK and then manually copy the files in the 8.0 folder.....

    well... let's try :-)

    thnx anyway,
    br
    jo'

  6. #6
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    Generally you can create application for new phone with old SDKs. Symbian and Nokia are trying to ensure backward binary compatibility. But it is not 100 per cent in all cases...

  7. #7
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    Ok. SIP stack for FP2 is available on Nokia's pages. Curiously enough it doesn't support N6630! I don't really know what to think about it...:-(

    http://www.forum.nokia.com/main/0,,034-561,00.html
    SIP plug-in 3.0 is compatible with all Series 60 Developer Platform 2nd Edition SDKs that support Feature Pack 2. (Please note! Nokia 6630 does not support SIP technology).

  8. #8
    Super Contributor
    Join Date
    Apr 2003
    Location
    Czech Republic
    Posts
    915
    btw, it may only mean that SIP libraries are not pre-installed on the device but will work with it....

  9. #9
    Registered User
    Join Date
    Nov 2004
    Posts
    38

    May only Mean

    Thats an awefully big "Mean". When you are faced with building an application and selecting target platforms there is no room for guess work. Why does Nokia not release more information regarding SIP migration path for the 6630? Either they support development of SIP apps for the N6630 using the new SDK and SIP plugin or they do not! It seems like the later.

    RE

  10. #10
    Registered User
    Join Date
    Aug 2004
    Posts
    32

    SIP application to N6630 phone?

    Hi,

    Have anybody successfully installed an own SIP application to N6630 phone?
    I have installed the SIP profile configuration tool, but have not been able to get my own SIP application to work on N6630 phone? The installation process goes fine, but when I try to start my app it just flashes the screen once and returns to menu view. (it wont start and no errors are displayed)
    I believe that some libraries are missing from the installation. It seems that the SIP profile configuration tool install some of the SIP libs and SIP server process.
    This is the content of my pkg file conserning the SIP libs. Can some body say what is missing or in overall, what might be the problem?

    ;libs used directly and used in mmp
    ;"\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPCLIENT.DLL" - "!:\system\libs\SIPCLIENT.DLL"
    ;"\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPCODEC.DLL" - "!:\system\libs\SIPCODEC.DLL"
    ;"\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SDPCODEC.DLL" - "!:\system\libs\SDPCODEC.DLL"
    ;"\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPPROFILECLI.DLL" - "!:\system\libs\SIPPROFILECLI.DLL"
    ;libs that are found from thumb urel dir
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\DEFLATECOMP.DLL" - "!:\system\libs\DEFLATECOMP.DLL"
    ;"\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIGCOMP.DLL" - "!:\system\libs\SIGCOMP.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPCLILAUNCHNOT.DLL" - "!:\system\libs\SIPCLILAUNCHNOT.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPDIGEST.DLL" - "!:\system\libs\SIPDIGEST.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPGPRSMON.DLL" - "!:\system\libs\SIPGPRSMON.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPIETFAGNT.DLL" - "!:\system\libs\SIPIETFAGNT.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPIMC1AGNT.DLL" - "!:\system\libs\SIPIMC1AGNT.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPREALMNOT.DLL" - "!:\system\libs\SIPREALMNOT.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPREQHAND.DLL" - "!:\system\libs\SIPREQHAND.DLL"
    "\Symbian\8.0a\S60_2nd_FP2\epoc32\release\thumb\urel\SIPSIGCOMP.DLL" - "!:\system\libs\SIPSIGCOMP.DLL"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •