×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    148

    Defect found in Nokia Series 80 PP SDK

    I found a defect in the latest Nokia Series 80 PP SDK (this includes the update that became available yesterday).

    The problem is this: The CCknInfoDialog does not exixt on the 9500. It also doesn't exists on the 9200, but that's less of a problem.

    How to show the existsence of this defect:

    I need to show a message using the CCknInfoDialog like this

    #include <ckninfo.h>
    replaceExistingFile = CCknInfoDialog::RunDlgLD(infoDialogTitle, textMsg);

    and linking with CKNDLG.LIB. This code compiles fine and also runs fine on this 9500 emulator, showing the title and the message as expected.

    But on a real 9500 device, I get a message saying that an object cannot be found.

    Ok, compiling the same code using the 9200 SDK, I still get the same problem on both devices.

    So I went back to my earlier code which looks like this:

    #include <eikinfo.h>
    CEikDialog* infoDialog = new(ELeave) CEikInfoDialog(infoDialogTitle, textMsg, CEikInfoDialog::EIgnoreEnter);
    replaceExistingFile = infoDialog->ExecuteLD(R_EIK_DIALOG_SINGLE_FILE_REPLACE);


    This code compiles and runs fine on my 9200 SDK. It does not compile on the 9500 SDK because eikinfo.h does not exist.
    This eikonfo-code also runs fine on the 9200 and on the 9500, using a sis file for the 9200.

    My conclusion is therefore that the 9500 SDK promises the existence of CCknInfoDialog, but code using this dialog cannot be run on a 9500, even though it compiles fine for the emulator and for the device, and it also runs fine on the emulator.

    Incidentally, the feedback link on the forum nokia website doesn't work.
    Sander van der Wal
    www.mBrainSoftware.com

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,144
    are you exatly sure about this ?, maybe it is some other library that is causing you the problem.

    At least in my 0.94 version prototype 9300 shows all of the dialogs wqithout any problems (unless if shown when starting up the app), and if I remember right my proto 9500 also showed the CCknInfoDialog withouot any problems what so ever.

    So check the CCknInfoDialog, with some helloworld app, and just add these two libs to the mmp file:
    LIBRARY ckndlg.lib
    LIBRARY eikdlg.lib

    yucca

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    148
    Originally posted by symbianyucca
    are you exatly sure about this ?, maybe it is some other library that is causing you the problem.

    At least in my 0.94 version prototype 9300 shows all of the dialogs wqithout any problems (unless if shown when starting up the app), and if I remember right my proto 9500 also showed the CCknInfoDialog withouot any problems what so ever.

    So check the CCknInfoDialog, with some helloworld app, and just add these two libs to the mmp file:
    LIBRARY ckndlg.lib
    LIBRARY eikdlg.lib

    yucca
    I am quite sure, but I'll check again (not today though). One thing is: this is for a control panel plugin, not an application.

    Sander

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,144
    Ok, just got a release version 9500 in my hand, and it is definetely working in that machine.

    So please check your implementation, the problem lies somewhere in your coding.

    yucca

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •