×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2004
    Posts
    10

    Problems upgrading to CodeWarrior 2.8.3

    Hi

    I've just upgraded from 2.5 -> 2.8.3 (in order to use the S60_2nd_FP2_CW SDK). I've had all sorts of problems tho.

    The upgrade has broken the Symbian Stationary Wizard, it no longer shows the UIQ SDK, and the 'Next' button is disabled regardless of what I select .

    Initially, I couldn't modify a target to use the new SDK, eventually I found I had to manually add an entry to the 'Symbian Environments' dialog.

    Then nothing would build, complaining that there was no define for __TText. this seemed to stem from the fact that __GCC32__ is not defined for ARMI builds?. I eventually just added it to the Macros section in the symbian Compiler panel.

    Now I get a 'Can't find XML Link Descriptor File for this target!' error message at the linking stage.

    Does this product actually work at all??

    Brendon

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399
    When you upgraded from 2.5 to 2.8.3 did you uninstall 2.5 first? Somehow your both your environment and registry seem to be out of synch with the current product and the import scripts in the SDK are getting confused (e.g. not generating a link descirptor file and missing macros).

    Also check and see if there are folders under this registry location:
    HKEY_LOCAL_MACHINE\SOFTWARE\Metrowerks\CodeWarrior\Product Versions

    Within those product folders there should be VERSION strings. The value should be 2.8.1 when using the 2.8.3 product. Do you still have other products in there with other values?

    Cheers,
    Tim

  3. #3
    Registered User
    Join Date
    May 2004
    Posts
    10
    Yes, I had (and still have) 2.5 installed. The registry has :
    Product Versions\CW For Symbian Personal 2.0
    Product Versions\CW For Symbian Personal 2.5
    Product Versions\CW For Symbian Personal 2.8

    The version string in 2.5 is 2.5, and in 2.8 is 2.8 (not 2.8.1)

    Do you think I should uninstall everything and start from scratch?

    Brendon

  4. #4
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399
    For a quick test you can set all your product values to 2.8.1 and try to import with ONLY 2.8.3 release (write them down in case you need to revert back). But don't try that with your other installs. But in general I would't recommend having all these products installed side-by-side. I think the miminum for using the SDK you have is CW 2.8.x since there are .cwlink files, which were introduced with 2.8.

    Chees,
    Tim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×