×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    44

    Playing amr on 6630

    Hi Everyone

    I'm converting pcm data to amr and playing the data using
    CMdaAudioOutputStream class,but although the callbacks
    for initializing and copying buffers are called, no sound is heard
    (I've set the volume to MaxVolume(),opened the device with
    mono chanells and 8000 Hz)Any ideas what the problem is?

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166
    you should propably be reading amr data and converting it to pcm (not converting pcm to amr) to be able to play it with CMdaAudioOutputStream. So try another way around, and maybe you'll get it working.

    yucca

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    44
    You are right ,I'm converting amr to pcm and playing it ,but only
    the first second is heard right and then I only hear noises,
    any ideas?

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166
    dunno really, mine is working just fine. Both recording & playing. Only thing I needed to remember was to add the "#!AMR\n" in front of the file when recording and to cut 6 bytes away when reading it.

    yucca

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    44
    it works ok now.It was just an additional offset I mistakenly
    added when reading the next buffer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×