×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2004
    Posts
    18

    SDK v2.6 configuration to get DNS lookup

    Hi,

    Our application makes use of TCP/IP connections, and the code works fine over PRNESOCK on earlier SDK's. For SDK v2.6, we would like to use the ethernet facilities available. The emulator is able to connect to the machine hosting the emulator, but is not able to connect to any other, implying that the DNS lookup is failing (despite the preferences showing the DNS entries to be the same as those for the PC).

    Has anyone else had problems configuring the SD v2.6 emualtor to use the LAN, and if so, did you find a way around them?

    thanks,
    Brendan

  2. #2
    Registered User
    Join Date
    Mar 2005
    Posts
    7

    sdk v2.1 lansettings

    Sockets example program:
    hi, having little bit similar problems. i am trying to connect to my socket server program from the emulator. The emulator socket app and socket server program are running on the same machine. I have no internet acces, just a local network without dhcp-server, no name servers etc.

    Current emulator lansettins from ced.cfg :

    [LANService]
    ADD_SECTION
    # COMMDB_ID = 1
    Name=LAN_service_1
    IfNetworks=ip,ip6
    IpNetMask=255.255.255.0
    IpGateway=0.0.0.0
    IpAddrFromServer=FALSE
    IpAddr=194.100.109.1
    IpDNSAddrFromServer=FALSE
    IpNameServer1=0.0.0.0
    IpNameServer2=0.0.0.0
    FIELD_COUNT=9
    END_ADD

    I am not able to connect the server socket program on the same machine. What is the problem? Do I need to set a gateway and nameservers in any case? I am not going to connect to the internet at all.

    js

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×