×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2004
    Posts
    27

    sync4j sync with the S60 emulator

    I have tried synchronizing with sync4j from the S60 2.1 emulator. As you guess I wasn't successful.

    Looking at the server logs the device initiation message was received sucecssfully, the device got logged in and a slow sync alert was sent by the server to the device. On the emulator side I get a "Server is not responding" error and if I open the sync log log the status says "Incomplete". Note that this was the first synchronization attempt between the emulator and the server.

    Has anyone tried using sync4j from the S60 emulator or from any other Nokia/UIQ emulator? I saw other forum entries saying that sync4j works with 6600 devices, I assume it should work with the emulator as well.

    The client initiation message and the server response:

    <SyncML>
    <SyncHdr>
    <VerDTD>1.1</VerDTD>
    <VerProto>SyncML/1.1</VerProto>
    <SessionID>10</SessionID>
    <MsgID>1</MsgID>
    <Target><LocURI>http://xx.xx.xx.xx:8080/sync4j/sync</LocURI></Target>
    <Source><LocURI>IMEI:xxxxxxxxxxxxxxx</LocURI></Source>
    <Cred><Meta><Type>syncml:auth-basic</Type></Meta><Data>c3luYzRqOnRlc3QxMjM0</Data></Cred>
    <Meta><MaxMsgSize>10000</MaxMsgSize></Meta>
    </SyncHdr>
    <SyncBody>
    <Alert>
    <CmdID>1</CmdID>
    <Data>201</Data>
    <Item>
    <Target><LocURI>./contacts</LocURI></Target>
    <Source><LocURI>./C\System\Data\Contacts.cdb</LocURI></Source>
    <Meta><Anchor><Last></Last><Next>20050209T194343Z</Next></Anchor></Meta>
    </Item>
    </Alert>
    <Put>
    <CmdID>2</CmdID>
    <Meta><Type>application/vnd.syncml-devinf+wbxml</Type></Meta>
    <Item>
    <Source><LocURI>./devinf11</LocURI></Source>
    <Data>
    <DevInf>
    <VerDTD>1.1</VerDTD>
    <Man>Unknown</Man>
    <Mod>Unknown</Mod>
    <SwV></SwV>
    <DevID>IMEI:053211596337247</DevID>
    <DevTyp>phone</DevTyp>
    <SupportLargeObjs />
    <SupportNumberOfChanges />
    <DataStore>
    <SourceRef>./C\System\Data\Contacts.cdb</SourceRef>
    <MaxGUIDSize>8</MaxGUIDSize>
    <Rx-Pref>
    <CTType>text/x-vcard</CTType>
    <VerCT>2.1</VerCT>
    </Rx-Pref>
    <Rx>
    <CTType>text/vcard</CTType>
    <VerCT>3.0</VerCT>
    </Rx>
    <Tx-Pref>
    <CTType>text/x-vcard</CTType>
    <VerCT>2.1</VerCT>
    </Tx-Pref>
    <SyncCap>
    <SyncType>1</SyncType>
    <SyncType>2</SyncType>
    <SyncType>3</SyncType>
    <SyncType>4</SyncType>
    <SyncType>5</SyncType>
    <SyncType>6</SyncType>
    <SyncType>7</SyncType>
    </SyncCap>
    </DataStore>
    <CTCap>
    <CTType>text/x-vcard</CTType>
    <PropName>BEGIN</PropName>
    <ValEnum>VCARD</ValEnum>
    <PropName>END</PropName>
    <ValEnum>VCARD</ValEnum>
    <PropName>VERSION</PropName>
    <ValEnum>2.1</ValEnum>
    <PropName>REV</PropName>
    <PropName>N</PropName>
    <PropName>ADR</PropName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <PropName>TEL</PropName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <ParamName>CELL</ParamName>
    <ParamName>PAGER</ParamName>
    <ParamName>FAX</ParamName>
    <PropName>FN</PropName>
    <PropName>EMAIL</PropName>
    <ParamName>INTERNET</ParamName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <PropName>URL</PropName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <PropName>NOTE</PropName>
    <PropName>TITLE</PropName>
    <PropName>ORG</PropName>
    <PropName>PHOTO</PropName>
    <PropName>BDAY</PropName>
    <CTType>text/vcard</CTType>
    <PropName>BEGIN</PropName>
    <ValEnum>VCARD</ValEnum>
    <PropName>END</PropName>
    <ValEnum>VCARD</ValEnum>
    <PropName>VERSION</PropName>
    <ValEnum>3.0</ValEnum>
    <PropName>REV</PropName>
    <PropName>N</PropName>
    <PropName>ADR</PropName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <PropName>TEL</PropName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <ParamName>CELL</ParamName>
    <ParamName>PAGER</ParamName>
    <ParamName>FAX</ParamName>
    <PropName>FN</PropName>
    <PropName>EMAIL</PropName>
    <ParamName>INTERNET</ParamName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <PropName>URL</PropName>
    <ParamName>HOME</ParamName>
    <ParamName>WORK</ParamName>
    <PropName>NOTE</PropName>
    <PropName>TITLE</PropName>
    <PropName>ORG</PropName>
    <PropName>PHOTO</PropName>
    <PropName>BDAY</PropName>
    </CTCap>
    </DevInf>
    </Data>
    </Item>
    </Put>
    <Get>
    <CmdID>3</CmdID>
    <Meta><Type>application/vnd.syncml-devinf+wbxml</Type></Meta>
    <Item><Target><LocURI>./devinf11</LocURI></Target></Item>
    </Get>
    <Final></Final>
    </SyncBody>
    </SyncML>


    <?xml version="1.0" encoding="UTF-8"?>
    <SyncML>
    <SyncHdr>
    <VerDTD>1.1</VerDTD>
    <VerProto>SyncML/1.1</VerProto>
    <SessionID>10</SessionID>
    <MsgID>26</MsgID>
    <Target><LocURI>IMEI:xxxxxxxxxxxxxxx</LocURI></Target>
    <Source><LocURI>http://xx.xx.xx.xxx:8080/sync4j/sync</LocURI></Source>
    <Meta><MaxMsgSize>10000</MaxMsgSize></Meta>
    </SyncHdr>
    <SyncBody>
    <Status>
    <CmdID>1</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>0</CmdRef>
    <Cmd>SyncHdr</Cmd>
    <TargetRef>http://xx.xx.xx.xx:8080/sync4j/sync</TargetRef>
    <SourceRef>IMEI:xxxxxxxxxxxxxxx</SourceRef>
    <Data>212</Data>
    </Status>
    <Status>
    <CmdID>2</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>1</CmdRef>
    <Cmd>Alert</Cmd>
    <TargetRef>./contacts</TargetRef>
    <SourceRef>./C\System\Data\Contacts.cdb</SourceRef>
    <Data>200</Data>
    <Item>
    <Data>
    <Anchor xmlns="syncml:metinf">
    <Next>20050209T194343Z</Next>
    </Anchor>
    </Data>
    </Item>
    </Status>
    <Status>
    <CmdID>3</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>2</CmdRef>
    <Cmd>Put</Cmd>
    <SourceRef>./devinf11</SourceRef>
    <Data>200</Data>
    </Status>
    <Status>
    <CmdID>4</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>3</CmdRef>
    <Cmd>Get</Cmd>
    <TargetRef>./devinf11</TargetRef>
    <Data>200</Data>
    </Status>
    <Results>
    <CmdID>5</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>3</CmdRef>
    <Meta>
    <Type>application/vnd.syncml-devinf+wbxml</Type>
    </Meta>
    <Item>
    <Source>
    <LocURI>./devinf11</LocURI>
    </Source>
    <Data>
    <DevInf xmlns="syncml:devinf">
    <VerDTD>1.1</VerDTD>
    <Man>SyncServer</Man>
    <Mod>-</Mod>
    <OEM>-</OEM>
    <FwV>-</FwV>
    <SwV>4.0.7</SwV>
    <HwV>-</HwV>
    <DevID>Sync4j SyncServer</DevID>
    <DevTyp>-</DevTyp>
    <DataStore>
    <SourceRef>./contacts</SourceRef>
    <MaxGUIDSize>32</MaxGUIDSize>
    <Rx-Pref>
    <CTType>text/x-vcard</CTType>
    <VerCT>1.0</VerCT>
    </Rx-Pref>
    <Rx>
    <CTType>text/x-vcard</CTType>
    <VerCT>1.0</VerCT>
    </Rx>
    <Tx-Pref>
    <CTType>text/x-vcard</CTType>
    <VerCT>1.0</VerCT>
    </Tx-Pref>
    <Tx>
    <CTType>text/x-vcard</CTType>
    <VerCT>1.0</VerCT>
    </Tx>
    <SyncCap>
    <SyncType>1</SyncType>
    <SyncType>2</SyncType>
    <SyncType>3</SyncType>
    <SyncType>4</SyncType>
    <SyncType>5</SyncType>
    <SyncType>6</SyncType>
    <SyncType>7</SyncType>
    </SyncCap>
    </DataStore>
    </DevInf>
    </Data>
    </Item>
    </Results>
    <Alert>
    <CmdID>6</CmdID>
    <Data>201</Data>
    <Item>
    <Target>
    <LocURI>./C\System\Data\Contacts.cdb</LocURI>
    </Target>
    <Source>
    <LocURI>./contacts</LocURI>
    </Source>
    <Meta>
    <Anchor>
    <Last>1107978228225</Last>
    <Next>1107978228225</Next>
    </Anchor>
    </Meta>
    </Item>
    </Alert>
    <Final></Final>
    </SyncBody>
    </SyncML>

  2. #2
    Registered User
    Join Date
    Mar 2004
    Posts
    27

    Solved

    Changed the URL setting on the server and it works.

  3. #3
    Registered User
    Join Date
    Aug 2006
    Posts
    1

    Re: sync4j sync with the S60 emulator

    Hi vtulai

    What did you change in the URL "Changed the URL setting on the server and it works."

    Please help I'm trying with a Nokia 6680 to sync to sync4j v2.3

    Thanks

  4. #4
    Registered User
    Join Date
    Mar 2004
    Posts
    27

    Re: sync4j sync with the S60 emulator

    This was quite a while ago - early 2005. As far as I remember what we did was to change the IP address of the server.uri property from the default “localhost” to the actual IP address of the Sync4j server. Unless this is done, only clients running locally on the same host as the server will be able to successfully sync. Also, the server must be stopped and restarted for changes to Sync4j.properties to take affect.

    In the end we got it working both wit the emulator and real devices.

  5. #5
    Registered User
    Join Date
    May 2007
    Posts
    2

    Re: sync4j sync with the S60 emulator

    Hi,

    I have downloaded SDK60 and installed but i am not able to set up device management.Any one having steps to configure simulator to act as DM client.


    Regards,
    Manjunath

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×