×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Jan 2005
    Posts
    63

    Question Camera Application Porting Problem

    Hi...

    i have developed an application of using onboard camera refering camera example given in forum Camera Example, I have also done in the same manner as in example but when i am porting to the device 6600 then application is not running.......why???.......how should i run that application on my device 6600??? is there anything else like plug-ins i have to install???

    Thankx in advance

    Amit

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143
    For 6600 you could basically make the camera app by using either Ecam or camera server implementation, they both should work just fine.

    anyway, could you tell more about the behaviour you are experiencing ? any crashes, any error notes shoewn ?

    yucca

  3. #3
    Regular Contributor
    Join Date
    Jan 2005
    Posts
    63
    hi yucca,

    now, i have used the camera example by modifying it little bit as per my application requirement as a plug-in in my another application and its working fine right now, if i will face any problem in future then i will let you know.......Thankx anyways..

    Amit

  4. #4
    Registered User
    Join Date
    Mar 2005
    Posts
    10

    I'm facing the same problem,

    Amit,
    can you share how you got this working?
    did you install the camera plugin sdk thing? (the large 135MB file)? <I was not able to do so it complains that I don't have the SDK or something in the install shield setup>

    I'm able to compile CameraApp (after removing reference to avkon.loc ) but the application quits in the emulator with no apparent error,

    I'm using Series 60 2nd Edition SDK for Symbian OS Supporting Feature Pack 2 for C++ Supporting Metrowerks CodeWarrior.

    any help mostly appriciated.
    all I want is to programmatically take a picture and do something with the image.
    thanx a bunch
    --tzurs.

  5. #5
    Regular Contributor
    Join Date
    Jan 2005
    Posts
    63
    dear,

    i haven't installed any camera plug-ins for that, instead i used that CameraApp example as plug-in and manipulated that code according to our application specific requirement. And that is working absolutely fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •