×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Oct 2004
    Posts
    52

    error building 3d example code

    Hi,
    I am trying to build an run the simplecube example that comes with the "Series 60 Developer Platform: Introduction To 3-D Graphics In C++ (With Example) v1.1 (ZIP)" from here (forum nokia).

    I have not altered any code, and I have all my gl and egl .h files in the epoc 32 include directory and the vc7 include directory.

    I am using Visual Studio .NET 2003 and I am creating a .sln file by running the "makmake simplecube vc7 command".

    When I try to build the solution created by makmake I get a number of errors that mostly look like this:

    SIMPLECUBE error LNK2019: unresolved external symbol __imp__glHint referenced in function "public: void __thiscall CSimpleCube::AppInit(void)" (?AppInit@CSimpleCube@@QAEXXZ)

    The last 3 errors are:

    SIMPLECUBE fatal error LNK1120: 27 unresolved externals

    SIMPLECUBE fatal error U1077: 'link.exe' : return code '0x460'

    SIMPLECUBE fatal error LNK1181: cannot open input file '\Symbian\7.0s\Series60_v21\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V21\SERIES60EX\3DEXAMPLES\OPENGLEX\SIMPLECUBE\GROUP\SIMPLECUBE\WINS\UDEB\SIMPLECUBE.exp'


    Any help would be greatly appreciated!
    Miranda

  2. #2
    Registered User
    Join Date
    Oct 2004
    Posts
    5
    you must add OpenglES into your mmp file before build application

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×