×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2005
    Posts
    2

    Unhappy Turning on bluetooth on emulator

    Hi Folks!

    I have installed okia_S40_DP20_SDK_1_1 on "C:\Nokia\Devices\Nokia_S40_DP20_SDK_1_1\"
    and would like to run a Bluetooth example J2ME from the book "Developing Scalable Series 40 Applications". When I go to the phone and try to turn the Bluetooth on the thing does not turn on !!! It always shows "Bluetooth off". How can it be ?!?!?!

    Yes, I have the Nokia Connectivity Framework started and it shows the device and some numbers for SMS, MMS and Bluetooth.

    Please, can someone help me on this? What Am i getting wrong?!

  2. #2
    Registered User
    Join Date
    Aug 2004
    Posts
    15
    Hi have you solved your problem yet?
    When I start NCF and S40 I am always
    seeing about 15 lines of bt log messages in the
    NCF log. I have however had sometimes
    problems to get BT working with the S40 emulator when I have started to instances of them very fastly. After that I have not
    been able to see S40 1.1 generating bt messages to NCF log.

    In that kind of situation the fix has been following
    1) I have closed S40 and NCF
    2) I have opened Windows task manager and checked that there is not any java processes running (I have killed them if there has been any left)
    3) I have restarted NCF and S40
    --> When S40 starts it should generate some
    bt log messages and I am able to turn the BT on in S40.

    I suggest you to also try NCF 1.2 and S40 2.0 emulators. Prototype 2.0.s has also worked fine for me.

  3. #3
    Registered User
    Join Date
    Jan 2005
    Posts
    2

    No go

    I cannot start Bluetooth with the default Nokia emulator (S40 DP 2.0 SDK 1.1) and the newer S40 DP 2.0 SDK - Nokia 6255 Edition 1.0.

    Can you help me where to look (log files, registry, etc.) for more info so we can compare some data?

    thanks for your kind help.

  4. #4
    Registered User
    Join Date
    Aug 2004
    Posts
    15

    How about following

    I am not sure from the registry settings.
    Are you using NCF 1.1 or NCF 1.2?

    As you are seeing the S40 emulators SMS/MMS and BT numbers in the NCF system tray icon, I believe
    that the NCF is detecting the emulators correctly and the problem is propaly caused by some other issue.

    Do you have somekind of firewall in your computer which could prevent MCF and S40 to communicate
    with each others? In S40 the menu tools/preferences/networking shows that S40 uses at least the port 1099 for something.

    I just made following test which works very reliably for me. If you do in a exactly same way
    can you see the BT log messages in NCF log screen just in a way I can see them?
    1) I closed NCF and all emulators.
    2) I opened windows task manager and checked that I do not have any of the following processes
    running java.exe, javaw.exe, rendezvous.exe, phonenumberregistry.exe and bluetoothdispatcher.exe
    (If you have any of them running, close them)
    3) I opened NCF full from the "Start/Nokia Developer Tools/Nokia Connectivity Framework/Nokia Connectivity Framework Full"
    4) NCF Log displayed messages "P2P ready" and "NCF Integration Library Connectivity Ready"
    5) Taskmanager processes shows that there is now running new processes rendezvous.exe, phonenumberregisty, bluetoothdispatcher and
    one javaw.exe
    6) I drag and dropped the S40 DP20 SDK, Nokia 6255 edition to NCF full environment
    7) I drag and dropped the SMSTest.jad MIDlet to S40 in the NCF environment (From the applications node of the tree)
    8) I pressed start environment button
    --> There appeared log "Started Series 40 DP20 SDK,..."
    --> I noticed that another javaw.exe process is also started by the S40 sdk
    --> NCF System tray displayed that S40 uses SMS/MMS number 6255000 and BT MAC address 000031127B35
    9) After that there also appeared about 15 log messages which has BT as type. I think this is an indication
    that the bluetooth is working
    10) I pressed red button of the S40 to close the MIDlet and selected menu/connectivity/bluetooth which
    shows that I have bluetooth "on"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×