×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Regular Contributor
    Join Date
    Nov 2004
    Location
    Mumbai - India
    Posts
    155

    In 8.0a/ SIP3.0 "SIPCLIENTINSTALLER.EXE" replaced with ?

    I'm using 8.0a and SIP 3.0.

    I hv 3 ques.

    [I]

    SIPCLIENTINSTALLER.EXE and SIPCLIENTUNINSTALLER.EXE replaced with ?

    [II]

    In chipflip example, xml file is using ID 101FBF71, which is not defined in any mmp file ?

    [III]
    My app invitation is throwing 488 error. most probably error regarding xml file. xml file is in epoc\wins\c.
    I also trying EPOC plugin as in chipflip.


    What's can be possible errors ?


    cheeeeeeeeeeers
    suraab
    Last edited by saurbh_g; 2005-02-26 at 07:11.

  2. #2
    Regular Contributor
    Join Date
    Oct 2004
    Location
    India
    Posts
    138
    Hey i know about the second question,
    i dont know about the chipflip example but if the xml file which you are mentioning is about SipAppCapabilities.xml file then the number should be your appUID it will be in mmp file.
    this is what i have in my mmp file
    ............
    TARGETTYPE app
    UID 0x100039CE 0x0DF9837E
    TARGETPATH \system\apps\SIPEX
    .................

    the number 0x0DF9837E
    is your app UIS the xml file number and the AppUID number in your mmp should match.

    Note: the preceding "0x" should not be written in your xml file.
    in this case "0DF9837E" should be placed inthe xml file.

    -chaitu

  3. #3
    Regular Contributor
    Join Date
    Nov 2004
    Location
    Mumbai - India
    Posts
    155
    Pls check out SIP 3.0. It's different. Even I compiled chipflip and my app without sipAppcapa.....xml.

    cheers

  4. #4
    Regular Contributor
    Join Date
    Oct 2004
    Location
    India
    Posts
    138
    Even in SIP1.0 app will compile without SipAppCapabilites.xml , what i think is this xml file is used by SIP plug-in, to deicde to which application to deliver the messages, what happens in SIP1.0 is if you have a mistake in XML file, then we get all types of errors.
    this is what i know.
    please correct if i am wrong,

    regards
    -chaitu

  5. #5
    Registered User
    Join Date
    Oct 2004
    Posts
    9
    HI Saurabh,
    Were u able to resolve the problem with the Sipcapabilities.xml
    I'm tried running my own app but INVITE fails with 488 response (Not Acceptable Here).
    If you have figured it out let me know.

    Regards,
    hsubahan

  6. #6
    Regular Contributor
    Join Date
    Nov 2004
    Location
    Mumbai - India
    Posts
    155

    yes ; at last.... :)

    Put eCom plugin DLL and application RSc file in this directory (\ is not present)....

    CSymbian8.0aS60_2nd_FP2epoc32releasewinsudebzsystemLibsPlugins

    check out RSG of ur app created by compiler. Put that at right place, i.e. ....
    CSymbian8.0aS60_2nd_FP2epoc32include

    That's it. One more thing, I used CHIPFLIP Ecomplugin instead of my own.Just changed 0xXXXXXXXX values.


    Cheers
    Saurabh

  7. #7
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    still cant get it running :-(

    Hi Saurabh,
    Thanks for your prompt reply.

    I also used the CHIPFLIPECOMPlugin. I modified the 1020691B.rss file.
    I changed the line:
    from default_data = "1020691A";
    to default_data = "10005917"; // My App UID.

    I made no other change.

    I compiled the code and put the ecom dll and rsc in the folder
    C:/Symbian8.0a/S60_2nd_FP2/epoc32/release/wins/udeb/z/system/Libs/Plugins

    Put the my apps .rsg in the EPOC32/Inlcude folder.

    Now, when i try to invite using the emulator i'm getting a SIP 603 error message recorded in the SIP server.

    What am i doing wrong?

    Thanks

    regards,
    hsubahan

  8. #8
    Regular Contributor
    Join Date
    Nov 2004
    Location
    Mumbai - India
    Posts
    155
    What About next line ...

    opaque_data = "<SIP_CLIENT ALLOW_STARTING=\"YES\"><SIP_HEADERS><ACCEPT value=\"application/sdp\"/></SIP_HEADERS><SDP_LINES><LINE name=\"m\" value=\"application 1025 tcp ****Appname u r using inSDP**** \"/></SDP_LINES></SIP_CLIENT>";


    **** -------***** App name need to be changed also.




    Suraab

  9. #9
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    thanks for the info...

    Hi Saurabh,
    Yes I have made that change. I was wondering you made any changes in 101fed88.ini file. My application was working fine with SIP 1.0 plugin but after I upgraded to 3.0 the INVITE message fails with 603 DECLINE.

    Thanks for your help.

    Regards,
    hsubahan

  10. #10
    Registered User
    Join Date
    May 2005
    Posts
    38
    Hi hsubahan,

    your problem is an exact replica of mine.. and I am yet to figure out a solution... did you find the solution ?

    plase share it if you have as I am basically stuck at this juncture and don't know what to do next.

    Tom

  11. #11
    Registered User
    Join Date
    May 2003
    Posts
    187
    SIPClientInstaller and uninstaller is not supported anymore , please read the manuals that come from nokia, you chould create a plug-in instead

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×