×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    61

    Problem: S60 SDK for CW in PC with .NET

    Hi,

    Got this problem with S60 SDKs for CW when .NET is installed on the same PC.

    Have installed:

    .NET v 7.0
    Codewarrior for Symbian OS 2.8.3 Personal
    S60 SDK for CW version 1.2

    I try to work with CW + S60 for CW, the .NET is installed only for other development than Symbian.

    Now, when I try to import an mmp file (Series60ex\Helloworld, untouched), to CW, first the cpp.exe crashes. Have checked the path, environment variables, all OK. Also devices command shows the right selected SDK. devices -info shows that the paths are correct. Perl is installed and working OK. A colleague solved this problem by finding that crash happened in cygwin1.dll. He downloaded the source for this dll and recompiled it. Now crash disappeared. Not the way to solve the problem in my mind, but it helped.

    Next problem. The uikon.rh fails to compile in the line where the AKN_EDITOR_EXTENSIONS is defined. Nothing wrong with that line, since it compiles OK on a machine without .NET. Because of this, the rss file is not succesfully compiled, so the app is not compiled.

    On the same PC, UIQ 2.1 SDK for CW has no problems whatsoever, so the problem is not with the installation of Codewarrior but with the S60 SDK for CW. Seems that it cannot cope with the situation where .NET is installed on the same machine (?).

    Have also tried to install S60 2nd ed FP2 for CW, did not solve this problem.

    Are my theories about this wrong; is there another known problem that should fix this or not?

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    61
    Just received a hint to run bldmake bldfiles once with an admin level account.

    This helped, now the SDK works correctly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×