×

Discussion Board

Results 1 to 3 of 3

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    7

    My Codewarrior Import Project wizard has disabled next button!

    Does anybody have any ideas why the "Next" button is disabled in my import mmp wizard?

    I have Symbian and Nokia as platform options and no matter what SDK I click the next button remains disabled.

    This tool is run from the file menu on Codewarrier professional. A collegue with a 15 eval version of same tool doesn't have this problem. I've just purchased and installed my license.
    Last edited by rboxall; 2005-03-02 at 00:17.

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399
    You may have a malformed name in your devices.xml. It should be of the form "com.<vendor>.<sdk>" without spaces or extra periods. Perhaps you can post what your devices.xml content is?

    Cheers,
    Tim

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    7

    Fixed!!

    Tim,

    You are correct! I followed instructions from Motorola for a new SDK and they had me add a device using.

    devices -add q: q: @Device:Motorola.com

    This was the problem. It seems that I need another .xxx on the end of this for it to work. I just edited the xml and added .UIQ2_1 on the end and all is well. The next button is back.

    So it seems that a device needs to be formated as

    @DeviceName:com.something.somethingelse

    i.e. @A1000:com.motorola.UIQ2_1

    This only seems to be a problem for Codewarrior as everything from the command line was ok.

    Thanks for the help.
    Robert

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •