×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    31

    NMSS 1.5 trouble

    Hello,

    I've setup
    - NMSS 1.5
    - S40 DP 2.0 SDK 1.1
    - java Terminating app with Lib. 1.5
    - java Sending app with Lib. 1.5

    NMSS 1.5 is listening in protocol MM7

    What works:
    - message #1
    Sent from java Sending app w/ Lib 1.5 to NMSS Emulator (message #1 SubmitReq/SubmitRsp)

    forwarding message #1 to S40 DP 2.0 SDK

    forwarding message #1 to terminating app

    don't work:
    - message #2
    Sent from S40 DP 2.0 SDK

    forward message #2 to terminating app
    => Terminating app crash, and return a soap message with
    <ns1:stackTrace xmlns:ns1="http://xml.apache.org/axis/">java.io.UTFDataFormatException: Invalid byte 1 of 1-byte UTF-8 sequence.
    at org.apache.xerces.impl.io.UTF8Reader.invalidByte(Unknown Source)
    ...

    I've dump what was sent to the terminating app (using GNU Netcat)

    This doesn't appear to be a SOAP message at all:
    ----------------------------------
    POST /axis/services/MMSServiceSOAPPortCallback HTTP/1.1
    x-nokia-mmsc-from: 6230011/TYPE=PLMN
    Content-Length: 524
    x-nokia-mmsc-service-type: FORWARD
    x-nokia-mmsc-message-id: 598dbd14e28242e0
    Content-Type: application/vnd.wap.mms-message
    x-nokia-mmsc-message-type: MultiMediaMessage
    x-nokia-mmsc-to: 11111/TYPE=PLMN
    x-nokia-mmsc-version: 3.0
    Cache-Control: no-cache
    Pragma: no-cache
    User-Agent: Java/1.4.2_03
    Host: 127.0.0.1:42100
    Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2
    Connection: keep-alive

    îÇÿR8wo (garbage binary)

    ---------------------------------------

    I would like to get any hint / advice for fixing this issue.

    btw: same setup with NMSS 1.5 and terminating app in EAIF protocol don't have this problem...

    Thanks in advance.
    Last edited by x_2001; 2005-03-14 at 08:27.

  2. #2
    Registered User
    Join Date
    Mar 2005
    Posts
    6

    http://mmsc1

    Hi x_2001,

    Are you able to see the MMS in the Series 40 DP 2.0 SDK? After I forwarded the MMS from NMSS emulator to the Series 40 2.0 SDK. It trying to retrieve the MMS from http://mmsc1. Do you face this problem? Any resolution? Thanks in advance.

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    31
    You can try to run from examples folder :
    ant run-mms-send-with-eaif
    or
    ant run-mms-send-with-mm7

    out-of-the-box it worked for me:
    I was able to forward messages to S40 DP 2.0 from NMSS without any problem (and messages were received correctly in S40 DP 2.0)


    That's the opposite which fails for me:
    sending from S40 DP 2.0 (message is seen in NMSS but NMSS isn't able to forward to terminating app in MM7, it only work in EAIF protocol).

  4. #4
    Registered User
    Join Date
    Mar 2004
    Posts
    19

    What JDK version do you use ?

    Hi x_2001

    NMSS 1.5 that you installed on your PC could sent MMS message to Nokia S40 Developer SDK 1.1. Unfortunetly, it doesn't work succesfully on my PC. Perhaps, it causes by JDK or JRE version. Can you tell me what JDK or JRE version you use on your PC, so NMSS 1.5 could work correctly ?

    Thank's

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    31

    jdk version

    I'm unsure which version of jdk I used, maybe 1.4.2_06
    imho any decent version work.

    there's even one jre included c:\Nokia\Server_SDKs\Emulator_1_5\Server\j2re1.4.2_03\

    by the way, I'm still expecting (since 3 weeks) either an acknowledgement from Nokia or a solution for my bug :)

  6. #6
    Registered User
    Join Date
    Mar 2004
    Posts
    19

    Other problems

    hi x_2001..

    have U try to test Library 1.5 example that runs SAMS MMS send and Receive application ?? Does it work on your PC environment ?

    on my PC environtment, this example did not work correctly, but in NMSS 1.4 this application work correctly. When I used NMSS 1.5 The MMS message can not be shown on Series 40 Developer platform SDK 2.0. Can U tell me how to correct this problem ??

    thank's

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    31

    yuck

    seno_ap: i didn't tried SAMS

    still no reply about 'my' bug

    is anyone here ?

  8. #8
    Registered User
    Join Date
    May 2005
    Posts
    4

    versions of jdk....

    same thing like: what is the version of your mouse driver? ohh no..is it important on your problem

    well, lets get back to your problem. I guess you need to track this down by yourself:

    are you sure, though your url has mm7soap in it, that you really receive soap-message.

    if you write binary garbage it might be "eaif" protocol?

  9. #9
    Registered User
    Join Date
    Mar 2003
    Posts
    31

    cockroach

    yes, it might be eaif (well I don't give a shit what it's infact, as long as it's _not_ doing what it should...)

    still no answer from anyone @nokia about this 'feature'

    cheers,

  10. #10
    Registered User
    Join Date
    May 2005
    Posts
    4

    stupid me

    hi,

    no, I was my fault -stupid me. nmss is working correct here - as fare as I can tell. now, I got it under control. was something completly different.

    see ya

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×