×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Apr 2004
    Posts
    14

    Unhappy Series 60 SDK woes

    So this is the 4th time I have sat down in the past year, determined to get a working Series 60 development environment going and I'm on the virge of giving up for the last time... so I'd really appreciate it if someone could help me out.

    At the moment I'm trying to get S60_2nd_FP2 up and running in Visual Studio .Net and I get this build error on the HelloWorld example application:

    ------ Build started: Project: HELLOWORLDBASIC, Configuration: Debug WINS Win32 ------

    Building resources from Helloworldbasic_caption.rss
    perl -S epocrc_ide7.pl -I "\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\DATA" -I "\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\INC" -I- -I "\Symbian\8.0a\S60_2nd_FP2\EPOC32\INCLUDE" -DLANGUAGE_SC -u "\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\DATA\Helloworldbasic_caption.rss" -o"\Symbian\8.0a\S60_2nd_FP2\EPOC32\RELEASE\WINS\UDEB\Z\SYSTEM\APPS\HELLOWORLDBASIC\HELLOWORLDBASIC_CAPTION.rSC" -h"\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\DATA\HELLOWORLDBASIC_CAPTION.rs~" -t"\Symbian\8.0a\S60_2nd_FP2\EPOC32\BUILD\SYMBIAN\8.0A\S60_2ND_FP2\SERIES60EX\HELLOWORLDBASIC\GROUP\HELLOWORLDBASIC\WINS\UDEB"
    Can't find epocrc_ide7.pl on PATH.
    NMAKE : fatal error U1077: 'perl' : return code '0x2'
    Stop.
    Project : error PRJ0019: A tool returned an error code from "Building resources from Helloworldbasic_caption.rss"

    I've search the epoc install directory for a file called epocrc_ide7.pl and it does not seem to exist.

    Where do I start unpicking this problem? I'm at a loss to explain the large number of series 60 apps out there, since I've wasted several days of my life in total, just trying to get a working environment together. Is it really _that_ hard?? :-?

    Any help much appreciated.

    Andy

  2. #2
    Regular Contributor
    Join Date
    Feb 2005
    Posts
    328
    What version of Visual Studio .NET are you using?

  3. #3
    Registered User
    Join Date
    Mar 2005
    Location
    Bristol, UK
    Posts
    19
    Hi - I had no problems setting everything up for MSVC++6. I have had compatibility problems with Visual Studio .net on other programming projects in the past so I tend to not use it at all now. Can you get your hands on a copy of MSVC++6?

  4. #4
    Registered User
    Join Date
    Jan 2005
    Posts
    11
    Its not easy, but it will work. I think the problem is that all the documentation makes too many assumptions about the users system and the way they will go about things.

    I eventually got this development kit running with visual studio 7. You have to ensure you use the developer studio command line when running all commands.

    To get to this point, what commands have you executed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×